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Abstract 
 

  

These Application Notes describe the steps for configuring Avaya IP Office Release 11.0 and 

Avaya Session Border Controller for Enterprise Release 8.0, with the AT&T IP Transfer 

Connect service AVPN or MIS/PNT transport connections. 
 

The AT&T IP Transfer Connect service is a service option available with the AT&T IP Toll 

Free service, and supports the rerouting of inbound toll free calls to alternate destinations 

based upon SIP redirection messages from Avaya IP Office Release. 

 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as the observations noted in Section 2.2, to ensure that their own use cases 

are adequately covered by this scope and results. 

 

Note that these Application Notes are intended to supplement the separate document: 

Application Notes for Avaya IP Office Release 11.0 and Avaya Session Border Controller for 

Enterprise Release 8.0 with the AT&T IP Toll Free Service – Issue 1.0. 

 

AT&T is a member of the Avaya DevConnect Service Provider program. Information in these 

Application Notes has been obtained through DevConnect compliance testing and additional 

technical discussions. Testing was conducted via the DevConnect Program at the Avaya 

Solution and Interoperability Test Lab. 

 



 
MAA; Reviewed: 

SPOC 9/10/2019 

Solution & Interoperability Test Lab Application Notes 

©2019 Avaya Inc. All Rights Reserved. 

 

2 of 27 

IPXC_IPO11SBCE8 

 

1. Introduction 
These Application Notes describe the steps for configuring Avaya IP Office Release 11.0 and 

Avaya Session Border Controller for Enterprise Release 8.0, with the AT&T IP Transfer 

Connect service and AVPN or MIS/PNT transport connections1. 

 

Avaya IP Office is a versatile communications solution that combines the reliability and ease of 

a traditional telephony system with the applications and advantages of an IP telephony solution. 

This converged communications solution can help businesses reduce costs, increase productivity, 

and improve customer service. 

 

These Application Notes describe the steps for provisioning Avaya IP Office Release 11.0 and 

the Avaya Session Border Controller for Enterprise Release 8.0 (Avaya SBCE), with the AT&T 

IP Transfer Connect service (IPTC). AT&T IP Transfer Connect is a service option available 

with the AT&T IP Toll Free service, and supports the rerouting of inbound toll free calls to 

alternate2 destinations based upon SIP redirection messages from Avaya IP Office. 

 

Note – These Application Notes are intended to supplement the separate document: Application 

Notes for Avaya IP Office Release 11.0 and Avaya Session Border Controller for Enterprise 

Release 8.0 with the AT&T IP Toll Free Service – Issue 1.0. This document is listed in Section 

10 as reference document [9]. It is recommended that this AT&T IP Toll Free service document 

should be available as a reference during provisioning to the AT&T IP Transfer Connect service. 

 

Note – The AT&T IP Transfer Connect service is referred to in the remainder of the document as 

IPTC. 

2. General Test Approach and Test Results 
DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The 

jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent 

to the interoperability of the tested products and their functionalities. DevConnect Compliance 

Testing is not intended to substitute full product performance or feature testing performed by 

DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or 

completeness of a DevConnect member’s solution. 
 

The interoperability compliance testing focused on verifying inbound call flows between IPTC 

and the Customer Premises Equipment (CPE) containing the Avaya IP Office Release 11.0 and 

Avaya SBCE 8.0 (see Section 3.2 for call flow examples). 

 

  

                                                 
1 MIS/PNT transport does not support compressed RTP (cRTP), however AVPN transport does support cRTP 
2 Note that this is NOT the same as the “Alternate Destination Routing (ADR)” service option available with the 

AT&T IP Toll Free service. 
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The test environment described in these Application Notes consisted of: 

• A simulated enterprise with Avaya IP Office; Avaya SBCE; Voicemail Pro; Avaya SIP, 

H.323, Digital and Analog telephones. 

• Laboratory versions of the IPTC service, to which the simulated enterprise was connected 

via AVPN/MIS transport. 
 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products. The testing referenced in this DevConnect 

Application Note included the enablement of supported encryption capabilities in the Avaya 

products. Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

                                                                                                     

Support for these security and encryption capabilities in any non-Avaya solution component is 

the responsibility of each individual vendor. Readers should consult the appropriate vendor-

supplied product documentation for more information regarding those products.  

 

For the testing associated with this Application Note, the interface between Avaya systems and 

the IPTC service did not include use of any specific encryption features as requested by AT&T. 

Encryption (TLS/SRTP) was used internal to the enterprise between Avaya products wherever 

possible. 

2.1. Interoperability Compliance Testing 

The compliance testing was based on a test plan provided by AT&T, for the functionality 

required for certification as a solution supported on the IPTC network. Calls were made from the 

PSTN across the IPTC test network, to the CPE. The interoperability compliance testing focused 

on verifying inbound call flows (see Section 3.2) between Avaya IP Office, Avaya SBCE and 

the IPTC service.  
 

The following SIP trunking VoIP features were tested with the IPTC service: 

• Inbound IPTC calls to Avaya IP Office SIP (1140E, J169 and Avaya Equinox softphone), 

H.323 (9608) and Digital (9508) telephones; utilizing G.729A codec (IPTC preferred 

codec).  

• Inbound IPTC calls that are immediately redirected by a SIP 302 message, generated by 

Avaya IP Office, back to the IPTC service for redirection to an alternate destination. 

• Inbound IPTC calls that are redirected by a SIP Refer (without Replaces) message, 

generated by Avaya IP Office/Voicemail Pro, back to the IPTC service for redirection to 

an alternate destination. However, in this case an announcement is played to the caller by 

Avaya IP Office/Voicemail Pro, prior to the redirection. 

• Verify reception of IPTC SIP Multipart/NSS headers, including SDP and XML content. 

• Avaya IP Office features such as hold, resume, and local transfer. 

• SIP OPTIONS messages used to monitor the health of the SIP trunks between the CPE 

and AT&T. 
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2.2. Test Results 

The test objectives stated in Section 2.1, with limitations as noted below, were verified. 

 

1. Avaya IP Office only supports a packet size (ptime) of 20 msecs. Although no issues 

were found during testing, AT&T recommends that for maximum customer bandwidth 

utilization, a ptime value of 30 msecs should be specified. 

 

2. Avaya IP Office does not support transmission of User-to-User (UUI) data. The 

IPTC service allows for the optional inclusion of UUI data in both 302 and Refer SIP 

messages. Although Avaya IP Office 11.0 supports passing UUI headers information on 

transit calls across a SIP trunk, it did not send any UUI data in the configuration tested. 

This issue is being investigated by Avaya IP Office development. 

 

3. Enhanced CID – NSS feature. The inbound calls to Avaya IP Office are not exercising 

the Enhanced CID feature. Although Avaya IP Office is accepting SIP Multipart/NSS 

headers, it is neither passing nor acting upon it, this data is simply being ignored. 

 

4. IPTC services IP InfoPack and Landline/Mobility test cases could not be executed. 

The AT&T supplied IPTC test plan specifies test cases to verify the inbound transmission 

of INFOPAK and Landline/Mobility data by the IPTC service. Due to network 

provisioning and support issues, these test cases could not be executed. 

2.3. Support 

AT&T customers may obtain support for the AT&T IP Transfer Connect service by calling (800) 

325-5555.  

 

Avaya customers may obtain documentation and support for Avaya products by visiting: 

http://support.avaya.com. In the United States, (866) GO-AVAYA (866-462-8292) provides 

access to overall sales and service support menus. Customers may also use specific numbers 

(provided on http://support.avaya.com) to directly access specific support and consultation 

services based upon their Avaya support agreements. 

http://support.avaya.com/
http://support.avaya.com/
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3. Reference Configuration 
The reference configuration used in these Application Notes is shown in Figure 1 on the next 

page and consists of the following components:  

• Avaya IP Office provides the voice communications services for a particular enterprise site. 

In the reference configuration, Avaya IP Office runs on the Avaya IP Office Server Edition 

platform. Note that this solution is extensible to deployments using the standalone IP500 V2 

platform as well.  

• In the sample configuration, the Primary server runs the Avaya IP Office Server Edition 

Linux software. Avaya Voicemail Pro, running as a service on the Primary Server, provided 

the “Modules” required to generate the Refer (without Replaces) SIP messaging (see Section 

5.3). 

• The Expansion System (V2) is used for the support of digital, analog and additional IP 

stations. It consists of an Avaya IP Office 500v2 with analog and digital extension expansion 

modules, as well as a VCM64 (Voice Compression Module). 

• Avaya endpoints are represented with an Avaya 9608 H.323 deskphone, an Avaya 9508 

Digital deskphone, Avaya J169 and 1140E SIP deskphones, as well as Avaya Equinox for 

Windows (SIP) softphone. 

• In the reference configuration, both the Avaya IP Office (interface “LAN 1”), and the Avaya 

SBCE (interface “A1”) are connected to the private CPE network. The Avaya SBCE 

interface “B1” is connected to the AT&T network. 

• The AT&T IPTC service requires the following SIP trunk network settings between the 

Avaya SBCE interface “B1” and the IPTC Border Element: 

o UDP transport using port 5060 

o RTP port ranges 16384-32767 

• AT&T provided the inbound access numbers (DID and DNIS) used in the reference 

configuration. Note that the IPTC service may deliver various digit lengths in the SIP Invite 

R-URI depending on the circuit order provisioning. In the reference configuration, the IPTC 

service delivered 10 digits.  

• An Avaya Remote Worker endpoint (Avaya Equinox for Windows) was used in the 

reference configuration. The Remote Worker endpoint resides on the public side of an Avaya 

SBCE (via a TLS connection), and registers/communicates with IP Office as though it was 

an endpoint residing in the private CPE space.  
 

Note – The configuration of the Remote Worker environment is beyond the scope of this 

document. Refer to [5] on the Additional References section for information on Remote Worker 

deployments. 

 

  



 
MAA; Reviewed: 

SPOC 9/10/2019 

Solution & Interoperability Test Lab Application Notes 

©2019 Avaya Inc. All Rights Reserved. 

 

6 of 27 

IPXC_IPO11SBCE8 

 

 
 

Figure 1: Reference Configuration 
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3.1. Illustrative Configuration Information 

The specific values listed in Table 1 below and in subsequent sections are used in the reference 

configuration described in these Application Notes, and are for illustrative purposes only. 

Customers must obtain and use the values based on their own specific configurations.  

  

Note – The Avaya SBCE “B1” interface communicates with AT&T Border Elements (BEs) 

located in the AT&T IPTC network. For security reasons, the IP addresses of the AT&T BEs are 

not included in this document. However, as placeholders in the following configuration sections, 

the IP addresses 192.168.80.43 (Avaya SBCE “B1”), and 192.168.225.210 (AT&T BE IP 

address), are specified. In addition, AT&T DID/DNIS numbers shown in this document are 

examples as well. AT&T Customer Care will provide the actual Border Element IP addresses 

and DID/DNIS numbers as part of the IPTC provisioning process. 

 

Component Illustrative Value in these 

Application Notes 

Avaya IP Office 

Private network LAN1 interface 10.64.19.170 

Expansion System, LAN1 Interface 10.5.5.180 

Avaya SBCE 

Private network “A1” interface. 10.64.91.41 

Public network “B1” interface. 192.168.80.43 

AT&T IPTC Service 

Border Element IP Address 192.168.225.210 

 

Table 1: Illustrative Values Used in these Application Notes 
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3.2. Call Flows 

To understand how inbound AT&T IPTC service calls are handled by Avaya IP Office, three 

basic call flows are described in this section.  

3.2.1. Basic Inbound Call 

The first call scenario illustrated in Figure 2 is an inbound IPTC service call that arrives at 

Avaya IP Office, and is subsequently routed to an endpoint. Note that no call redirection is 

performed in this scenario. 

 

1. A PSTN phone originates a call via the IPTC service. 

2. The PSTN routes the call to the IPTC service network. 

3. The IPTC service routes the call to the Avaya SBCE. 

4. The Avaya SBCE performs SIP Network Address Translation (NAT) and any necessary 

SIP header modifications, and routes the call to Avaya IP Office. 

5. Depending on the called number, Avaya IP Office routes the call to the associated 

endpoint. 

 

 
 

Figure 2: Inbound IPTC Call – No Redirection 
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3.2.2. 302 Call Redirection 

Note: In the call scenarios that follow, the term “alternate destination” does NOT refer to the 

“Alternate Destination Routing (ADR)” service option of the AT&T IP Toll Free service. ADR 

and the IPTC service are unrelated. 
 

The second call scenario illustrated in Figure 3 is an inbound IPTC service call that arrives at 

Avaya IP Office, which in turn generates the 302 SIP message.  

1. Same as the first three steps from the call scenario illustrated in Section 3.2.1. 

2. Avaya IP Office redirects the call by sending a SIP 302 message back out the SIP trunk 

(see Section 5.2.1). The SIP 302 message is routed back to the IPTC network. Avaya IP 

Office releases the trunk.  

3. The IPTC service places a call to the alternate destination and upon answer, connects the 

calling party to the target party (alternate destination). 

 

Note that no audio is transmitted between Avaya IP Office and the PSTN caller during the 302 

transaction. 
 

 
 

Figure 3: Inbound IPTC Call – SIP 302 Redirection 
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3.2.3. Refer Call Redirection 

The third call scenario illustrated in Figure 4 is an inbound IPTC service call that is routed to 

Avaya IP Office, which routes the call to Voicemail Pro. A predefined Voicemail Pro Module 

redirects the call back to the IPTC service using a Refer3, for routing to an alternate destination. 

1. Same as the first step from the call scenario illustrated in Section 3.2.2. 

2. Avaya IP Office routes the call to Voicemail Pro. 

3. Voicemail Pro executes a corresponding Module (see Section 5.3), which plays an 

announcement back to the PSTN caller, stating that the call is being redirected. 

4. Voicemail Pro redirects the call by sending a SIP Refer (without Replaces) message back 

out on the SIP trunk. The SIP Refer message is sent to the IPTC service network. Avaya 

IP Office releases the trunk. The IPTC service places a call to the alternate destination 

and upon answer, connects the calling party to the target party (alternate destination). 
 

 
 

Figure 4: Inbound IPTC Call –SIP REFER Redirection 

 

                                                 
3 This is a Refer without the Replaces parameter (i.e., a “Blind Refer”). 
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4. Equipment and Software Validated 
The following equipment and software were used for the reference configuration described in 

these Application Notes.  

 

Equipment/Software Release/Version 

Avaya 

Avaya IP Office Server Edition 

- Avaya IP Office Voicemail Pro 

Release 11.0.4.1.0 Build 11 

Release 11.0.4.0.0 Build 2 

Avaya IP Office 500 V2 Expansion System Release 11.0.4.1.0 Build 11 

Avaya IP Office Manager Release 11.0.4.1.0 Build 11 

Avaya Session Border Controller for Enterprise Release 8.0.0.0-19-16991 

Avaya 96x1 Series IP Deskphone (H.323) Release 6.8002 

Avaya 1140E IP Deskphone (SIP) Release 04.04.23.00 

Avaya J169 IP Deskphone (SIP) Release 4.0.0.21 

Avaya Equinox for Windows Release 0.60 

Avaya 9508 Digital Deskphone Release 3.6.0.153.36 

 

Table 2: Equipment and Software Versions 

 

Note – Compliance Testing is applicable when the tested solution is deployed with a standalone 

IP Office 500 V2, and also when deployed with all configurations of IP Office Server Edition. IP 

Office Server Edition requires an Expansion IP Office 500 V2 to support analog or digital 

endpoints or trunks. 
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5. Avaya IP Office Configuration 

Note – Avaya IP Office administration for interaction with the AT&T IP Toll Free service is 

described in document [9] and is applicable for the IPTC service as well (see the note in  

Section 1). This section describes the additional administration steps on Avaya IP Office 

necessary for supporting interaction with the IPTC service. It is recommended that the AT&T IP 

Toll Free service document should be available as a reference during provisioning to the AT&T 

IP Transfer Connect service. 

 

IP Office is configured via the IP Office Manager program. For more information on IP Office 

Manager, consult reference [4]. From the IP Office Manager PC, select Start → All Apps → IP 

Office → Manager to launch the Manager application. Navigate to File → Open 

Configuration (not shown), select the proper Avaya IP Office system from the pop-up window, 

and log in using the appropriate credentials.  

 

 
 

The appearance of the IP Office Manager can be customized using the View menu. In the 

screens presented in this section, the View menu was configured to show the Navigation pane on 

the left side, the Group pane in the center, and the Details pane on the right side. 
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5.1. SIP Line 

The following sections describe the configuration of a SIP Line. The SIP Line terminates the 

CPE end of the IP Office SIP trunk to the Avaya SBCE, and ultimately to the AT&T IPTC 

service. 

 

The recommended method for creating/configuring a SIP Line is to use the template associated 

with the provisioning described in these Application Notes. The template is an .xml file that can 

be used by Avaya IP Office Manager to create a new SIP Line for SIP trunking with the AT&T 

IPTC service. 

 

Follow the steps in Sections 5.5.1 of document [9] to import/create a SIP Trunk from the 

template. 

 

Note - In document [9], SIP Line 15 was created for use with the AT&T IP Toll Free service. 

SIP Line 15 was used for the IPTC testing as well, and is referenced in the following sections. 

5.1.1. SIP Line – SIP Line tab 

The SIP Line tab is shown below for the existing Line Number 15 (see the note above). This 

SIP Line form is modified as follows for the IPTC service: 

• Check the box next to Send 302 Moved Temporarily. 

• Check the box next to Outgoing Blind Refer. 

• Click on OK. 
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5.1.2. SIP Line – SIP Advanced Tab 

Navigate to SIP Line → SIP Advanced tab. 

• Verify that the Emulate NOTIFY for REFER is not checked. 

• Click on OK. 
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5.2. Incoming Call Routes to Trigger 302 or Refer Call Redirection 

Two call redirection methods are supported by the IPTC service; SIP 302 and Refer (without 

Replaces). While both of these methods utilize the Avaya IP Office Incoming Call Route table, 

the Destinations specified for each are different. The 302 redirection is triggered by Avaya IP 

Office, while the Refer redirection is triggered by a Module defined in Voicemail Pro. 

 

Note – In the reference configuration the IPTC service provided the access number 11041 for 

use in the 302 and Refer testing. 

 

Note – Although the IPTC is an inbound only service, an outbound Avaya IP Office Short 

Code must be defined to trigger the 302 and Refer Call Redirections. See Section 5.4. 

5.2.1. 302 Call Redirection 

In the example below, the incoming number 0000031043 is directed to trigger the 302 Call 

Redirection. 

 

1. From the Incoming Call Route page, select the Standard tab and enter the following: 

• Line Group ID: Enter the SIP Line previously defined in Section 5.5 of document [9] 

(e.g., 15). 

• Incoming Number: Enter the associated DNIS digits sent by AT&T (e.g., 0000031043). 

• Use default values for the remaining fields. 
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2. Select the Destinations tab and enter the following: 

• Enter the string 711041 to the drop down menu, and click OK (not shown).  

 

In this example, 7 is the outbound dialing Short Code (see Section 5.4), and 11041 is the IPTC 

defined access number to be used for the call redirection. 

 

 
 

When the 0000031043 number is received in an Invite, Avaya IP Office will generate a 302 

message, with 11041 in the Contact header, back to the IPTC service. The IPTC service will then 

generate a new Invite to the 11041 destination. 

5.2.2. Refer Call Redirection 

In the reference configuration, Voicemail Pro (running on Primary server), is used to send a 

Refer (without Replaces) Call Redirection. A Voicemail Pro “Module” is defined with the name 

Refer (see Section 5.3). This Module name is defined as a Destination to an inbound call as 

follows: 

1. From the Incoming Call Route page, select the Standard tab enter the following: 

• Line Group ID: Enter the SIP Line previously defined in Section 5.5 of document [9] 

(e.g., 15). 

• Incoming Number: Enter the associated DNIS digits sent by AT&T (e.g., 0000021042). 

• Use default values for the remaining fields. 
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2. Select the Destinations tab and enter the following: 

• In the Destinations column, enter the string VM:ATT_IPTC to the drop down menu, 

and click OK (not shown). 

 

In this example, VM: specifies that the destination is a Module on Voicemail Pro, and 

ATT_IPTC is the name of the Module (see Section 5.3). 

 

 
 

When the 0000021042 number is received in an Invite, Avaya IP Office/Voicemail Pro will play 

and announcement to the caller, then generate a Refer (without Replaces) message, (with 11041 

in the Refer-To header), back to the IPTC service. The IPTC service will then generate a new 

Invite to the 11041 destination. 

5.3. Voicemail Pro Refer Module 

Note - While Avaya Voicemail Pro provisioning and programming is beyond the scope of this 

document, a sample Module is described below.  

 

The Refer Module is provisioned to play an announcement to the caller, and then generate a 

Refer (without Replaces) back to the IPTC service. This is accomplished via the following steps 

via the Voicemail Pro Client interface: 

 

1. Open the Voicemail Pro Client application (not shown). 

2. Create a Start Point by right clicking on Modules and selecting Add. 
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3. Enter a name (e.g., ATT_IPTC) and click on OK (not shown). The new script 

“ATT_IPTC” will appear under Modules and a Start Point icon will appear in the work 

area. 

 

 
 

• Click on the Start Point icon  to activate the script options at the top of the 

screen. From the options, Telephony Actions icon , select the Transfer icon  and 

click on the work area to place the Transfer icon in the work area.  
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4. Double click on the Transfer icon. On the General tab → Token Name field, enter 

Refer (not shown). 

5. Select the Entry Prompts tab and select or create an announcement to be played to the 

caller prior to the Refer (e.g., refer.wav). To modify an existing recording, double click 

on the .wav file and rerecord. If no .wav files exist, double click on the  icon to open 

the .wav file editor. 

 

 
 

6. On the Specific tab enter 711041, where 7 is the Avaya IP Office outbound Short Code, 

and 11041 is the redirection number specified by the IPTC service (see Section 5.2.2). 

7. Click on OK. 
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8. From the options bar, select the Connector icon  and drag a connecting flow line 

from the Start Point box to the Transfer box. 

 

 
 

9. From the top menu select File → Save & Make Live, or select the  icon. 

 

When the IPTC DNIS number is received (e.g., 0000021042), IP Office sends the call to 

Voicemail Pro (see Section 5.2.2). The caller will hear an announcement (e.g., refer.wav), and 

Voicemail Pro/Avaya IP Office sends a Refer back to the IPTC service, specifying 11041 in the 

Refer-To header. The IPTC service will then send a new Invite to the 11041 destination. 

5.4. Outbound Short Code for 302 and Refer Call Redirection 

Avaya IP Office provides predefined Short Codes, however new Short Codes may be defined to 

match number strings to an action. To add a Short Code, right click on Short Code in the 

Navigation pane, and select New (not shown). To edit an existing Short Code, click Short Code 

in the Navigation pane, and the Short Code to be configured in the Group pane. 

 

Note – Although the IPTC is an inbound only service, an outbound Short Code must be 

defined to trigger the 302 and Refer Call Redirections.  

 

In the following screen, the Short Code 7N; is illustrated (note the semicolon at the end of the 

string). This Short Code will allow Avaya IP Office to generate a 302 or Refer message back to 

the IPTC service (see Sections 5.2 and 5.3). 

 

1. Right click on Short Codes from the left hand menu and select New (not shown). 

• The Code parameter is set to 7N; (note that 7 was used in the reference configuration, 

however any available number string may be used). 

• The Feature parameter is set to Dial. 

• The Telephone Number parameter is set to N. 
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• The Line Group ID parameter is set to the SIP Line previously defined in Section 5.4 of 

document [9] (e.g., 15). 

• Click the OK button (not shown). 

 

 

5.5. Saving Configuration Changes to Avaya IP Office 

The provisioning changes made in Avaya IP Office Manager must be applied to the Avaya IP 

Office server in order for the changes to take effect. At the top of the Avaya IP Office Manager 

page, click File → Save Configuration (if that option is grayed out, no changes are pending). 

 

A screen similar to the one below will appear, with either Merge or Reboot automatically 

selected, based on the nature of the configuration changes. The Merge option will save the 

configuration change with no impact to the current system operation. The Reboot option will 

save the configuration and cause the Avaya IP Office server to reboot. Click OK to execute the 

save. 
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6. Avaya Session Border Controller for Enterprise 
Avaya SBCE configuration for interaction with the AT&T IP Toll Free service provided in 

document [9] should also be followed for interoperability with the IPTC service. No additional 

administration steps are required on the Avaya SBCE for supporting interaction with the IPTC 

service. 

7. AT&T IP Transfer Connect service Configuration 
AT&T provides the IPTC service border element IP address, the access DID numbers, and the 

associated DNIS digits used in the reference configuration. In addition, the AT&T IPTC features, 

and their associated access numbers, are also assigned by AT&T. AT&T requires that the Avaya 

SBCE public (B1) IP address be provided to the IPTC service, as part of the provisioning 

process. 

8. Verification Steps 
The following procedures may be used to verify Avaya IP Office R11.0 with the AT&T IP 

Transfer Connect service configuration. 

8.1. Call Verification Tests 

The call verification steps and troubleshooting tools described for the AT&T Toll Free service 

described in document [[9]], also apply to the IPTC service. However additional verification 

steps specific to the IPTC service are described below. 
  

1. Place an inbound call to an IPTC service line enabled with Redirect features. Verify that 

Avaya IP Office redirects the call back to the IPTC service for redirection to an alternate 

destination using 302. Verify that the 302 message contains the redirection number in the 

Contact header. Verify two-way talk path and transmission between the caller and the 

redirected destination. 

2. Place an inbound call to an IPTC service line enabled with Refer features. Verify that 

Avaya IP Office directs the call to Voicemail Pro, which then redirects the call back to 

the IPTC service using Refer (without Replaces) for redirection to an alternate 

destination. Verify that the caller hears an announcement prior to the call redirection. 

Verify that the Refer message contains the redirection number in the Refer-To header, 

and that the Refer-To header does not contain a “Replaces” parameter. Verify two-way 

talk path and transmission between the caller and the redirected destination. 

8.2. System Monitor Traces 

Monitor the SIP traffic at the connection to the IPTC service, using IP Office System Monitor. 

The System Monitor application can typically be accessed from Start → Programs → Avaya 

IP Office → Monitor. 
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8.2.1. 302 Redirection 

The following is an example of a 302 redirection.  

The Contact header contains the new destination number (11041) as defined in the Avaya IP 

Office Incoming Call Route Destination field (see Section 5.2.1). The IPTC service will then 

generate a new Invite to the 11041 destination. 
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8.2.2. Refer  

The following is an example of a Refer redirection.  

• The Refer-To header contains the new destination number (11041) as defined in the 

Voicemail Pro Refer Module (see Section 5.3). Also note that the Refer-To header does 

not contain a “Replaces” parameter. 
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9. Conclusion 
As illustrated in these Application Notes, Avaya IP Office Release 11.0, and the Avaya Session 

Border Controller for Enterprise Release 8.0 can be configured to interoperate successfully with 

the AT&T IP Transfer Connect service, within the limitations described in Section 2.2.  
 

The sample configuration shown in these Application Notes is representative of a basic 

enterprise customer configuration and is intended to provide configuration guidance to 

supplement other Avaya product documentation. It is based upon formal interoperability 

compliance testing as part of the Avaya DevConnect Service Provider program. 
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