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Abstract 
 

  

These Application Notes describe the steps for configuring Avaya IP Office Release 11.1 

with the AT&T IP Flexible Reach - Enhanced Features service using AVPN or ADI/PNT 

transport connections.  
 

The AT&T IP Flexible Reach - Enhanced Features service is one of several SIP-based Voice 

over IP (VoIP) services offered to enterprises for a variety of voice communications needs. 

The AT&T IP Flexible Reach service allows enterprises in the U.S.A. to place outbound local 

and long-distance calls, receive inbound Direct Inward Dialing (DID) calls from the PSTN, 

and place calls between an enterprise’s sites.  

 

These Application Notes complement previously published Application Notes by illustrating 

the configuration screens and Avaya testing of IP Office Release 11.1. 

 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as the observations noted in Section 2.2, to ensure that their own use 

cases are adequately covered by this scope and results. 

 

AT&T is a member of the Avaya DevConnect Service Provider program. Information in 

these Application Notes has been obtained through DevConnect compliance testing and 

additional technical discussions. Testing was conducted via the DevConnect Program at the 

Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the steps for configuring Avaya IP Office Release 11.1 with 

the AT&T IP Flexible Reach - Enhanced Features service using AT&T Virtual Private 

Network (AVPN) or AT&T Dedicated Internet Service (ADI/PNT) transport connections. 

 

Avaya IP Office is a versatile communications solution that combines the reliability and ease 

of a traditional telephony system with the applications and advantages of an IP telephony 

solution. This converged communications solution can help businesses reduce costs, increase 

productivity, and improve customer service. 

 

The AT&T IP Flexible Reach - Enhanced Features service is one of several SIP-based Voice 

over IP (VoIP) services offered to enterprises for a variety of voice communications needs. The 

AT&T IP Flexible Reach - Enhanced Features service allows enterprises in the U.S.A. to place 

outbound local and long-distance calls, receive inbound Direct Inward Dialing (DID) calls from 

the PSTN, and place calls between an enterprise’s sites. The AT&T IP Flexible Reach - 

Enhanced Features service utilizes AT&T AVPN1 or ADI/PNT2 transport services. 

 

Note – The AT&T IP Flexible Reach - Enhanced Features service will be referred to as 

IPFR-EF in the remainder of this document. 

  

 
1 AVPN supports compressed RTP (cRTP). 
2 ADI/PNT does not support cRTP. 
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2. General Test Approach and Test Results 
DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. 

The jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces 

pertinent to the interoperability of the tested products and their functionalities. DevConnect 

Compliance Testing is not intended to substitute full product performance or feature testing 

performed by DevConnect members, nor is it to be construed as an endorsement by Avaya of 

the suitability or completeness of a DevConnect member’s solution. 
 

The interoperability compliance testing focused on verifying inbound and outbound call flows 

between IPFR-EF and the Customer Premises Equipment (CPE) containing the Avaya IP 

Office Release 11.1 (see Section 3.2 for call flow examples).  

 

The test environment described in these Application Notes consisted of: 

• A simulated enterprise with Avaya IP Office Release 11.1, Avaya SIP, H.323 and 

Analog telephones, as well as a fax machine emulator (Ventafax). 

• An IPFR-EF production circuit, to which the simulated enterprise was connected via 

AVPN transport. 

 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products. The testing referenced in this DevConnect 

Application Note included the enablement of supported encryption capabilities in the Avaya 

products.  Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

                                                                                                     

Support for these security and encryption capabilities in any non-Avaya solution component is 

the responsibility of each individual vendor.  Readers should consult the appropriate vendor-

supplied product documentation for more information regarding those products.  

 

For the testing associated with this Application Note, the interface between Avaya systems 

and the AT&T Flexible Reach service did not include use of any specific encryption features 

as requested by AT&T. 

 

Encryption (TLS/SRTP) was used internal to the enterprise between Avaya products wherever 

possible. 
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2.1. Interoperability Compliance Testing 

The compliance testing was based on a test plan provided by AT&T, for the functionality 

required for certification as a solution supported on the IPFR-EF network. Calls were made 

from the PSTN across the IPFR-EF network, to the CPE.  

 

The following SIP trunking VoIP features were tested with the IPFR-EF service: 

• Incoming and outgoing voice calls between PSTN, the IPFR-EF service, and Avaya IP 

Office, utilizing Avaya SIP telephones (desk and softphone), H.323 telephones (desk). 

• Inbound/Outbound fax calls using T.38 or G.711ULAW. 

• Various outbound PSTN destinations including local, long distance, international, and 

toll-free. 

• Requests for privacy (i.e., caller anonymity) for Avaya IP Office outbound calls to the 

PSTN, as well as privacy requests for inbound calls from the PSTN to Avaya IP Office 

users. 

• SIP OPTIONS messages used to monitor the health of the SIP trunk from both Avaya 

IP Office and AT&T. 

• Incoming and outgoing calls using the G.729A and G.711 ULAW codecs. 

• Call redirection with Diversion Header. 

• Long duration calls. 

• DTMF transmission (RFC 2833) for successful PSTN and Avaya IP Office menu 

navigation. 

• Telephony features such as hold, transfer, and conference. 

• Avaya IP Office Mobile Twinning to a mobile phone when the associated Avaya IP 

Office extension is called, as well as Mobility features such as Mobile Callback and 

Mobile Call Control. 

• AT&T IPFR-EF service features such as: 

o Simultaneous Ring 

o Sequential Ring 

o Call Forward – Always 

o Call Forward – Busy 

o Call Forward – Ring No Answer 

o Blind and Attended transfers utilizing SIP REFER messaging. 
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2.2. Test Results 

The test objectives stated in Section 2.1, with limitations as noted below, were verified.  

 

1. Avaya IP Office only supports a packet size (ptime) of 20 msecs – AT&T 

recommends that for maximum customer bandwidth utilization, a ptime value of 30 

should be specified. Avaya IP Office only supports a ptime value of 20 msecs, and 

therefore does not specify a ptime value in the SIP SDP (in either requests or 

responses). No issues were observed during testing as a result. 

 

2. Fax Support 

• Inbound T.38 fax calls fail when the CPE fax machine is a Super G3 (SG3) fax 

device. Avaya IP Office may not send a re-INVITE to renegotiate to T.38 for 

inbound fax calls in cases where both the PSTN and CPE fax devices support 

Super Group 3 (SG3) speeds. If the SG3 connection is fully established at the 

beginning of the call, the CPE fax device may not negotiate down to G3 speeds 

and IP Office will not detect the G3 tones necessary for T.38.  

• G.711 fax calls behaved unpredictably during the compliance test. Disabling 

Error Correction Mode on the CPE fax device seemed to modestly improve the 

G711 fax success rate. 

• T.38 should be the preferred method for fax. If the CPE device supports SG3 

speeds (33600 bps), a good practice is to disable SG3 on the CPE fax device, if 

possible. 

 

3. SIP OPTIONS – AT&T responded with “405 Method Not Allowed” to the SIP 

OPTIONS messages sent from the Avaya IP Office to the network used to monitor the 

status of the SIP trunk. The IP Office considers this as an acceptable response to keep 

the trunk in service.  

 

4. Emergency 911/E911 Services Limitations and Restrictions – Although AT&T 

provides 911/E911 calling capabilities, AT&T does not warrant or represent that the 

equipment and software (e.g., IP PBX) documented in these Application Notes will 

properly operate with AT&T IP Flexible Reach to complete 911/E911 calls; therefore, 

it is the customer’s responsibility to ensure proper operation with the 

equipment/software vendor. 

 

While AT&T IP Flexible Reach services support E911/911 calling capabilities under 

certain Calling Plans, there are circumstances when the E911/911 service may not be 

available, as stated in the Service Guide for AT&T IP Flexible Reach found at 

http://new.serviceguide.att.com. Such circumstances include, but are not limited to, 

relocation of the end user’s CPE, use of a non-native or virtual telephone number, 

failure in the broadband connection, loss of electrical power, and delays that may 

occur in updating the Customer’s location in the automatic location information 

database. Please review the AT&T IP Flexible Reach Service Guide in detail to 

understand the limitations and restrictions. 

http://new.serviceguide.att.com/
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2.3. Support 

For more information on the AT&T IP Flexible Reach service visit: 

https://www.business.att.com/products/sip-trunking.html. AT&T customers may obtain 

support for the AT&T IP Flexible Reach service by calling (877) 288-8362.  

 

Avaya customers may obtain documentation and support for Avaya products by visiting 

http://support.avaya.com. In the United States, (866) GO-AVAYA (866-462-8292) provides 

access to overall sales and service support menus. 

3. Reference Configuration 
The reference configuration used in these Application Notes is shown in Figure 1 below and 

consists of the following components: 

 

• Avaya IP Office provides the voice communications services for a particular enterprise 

site. In the reference configuration, Avaya IP Office runs on the Avaya IP Office Server 

Edition platform. This solution is extensible to the IP 500 V2 platform as well. 

• Avaya endpoints are represented by Avaya 9608 H.323 Deskphones, Avaya J169 SIP 

Deskphones, an Avaya 1140E SIP Deskphones, Avaya 9508 Digital Telephones, as well 

as Avaya IX™ Workplace for Windows (SIP) softphones. Fax endpoints are represented 

by PCs running Ventafax emulation software connected by modem to an Avaya IP Office 

analog port. 

• Voicemail Pro (running on the Primary server) provided the voice messaging capabilities 

in the reference configuration. This solution is extensible to the Avaya IP Office 

embedded voice mail as well. 

• In the reference configuration, Avaya IP Office interface “LAN 1” (labeled LAN) is 

connected to the private CPE, and interface “LAN 2” (labeled WAN) is connected to the 

public network and AT&T. 

• The AT&T IPFR-EF service requires the following SIP trunk network settings between 

the Avaya IP Office LAN 2 (SIP Trunk) interface and the IPFR-EF Border Element: 

o UDP transport using port 5060 

o RTP port ranges 16384-32767 

• AT&T provided the inbound and outbound access numbers (DID and DNIS) used in the 

reference configuration. Note that the IPFR-EF service may deliver 10 or 7 digits in the 

SIP Invite R-URI depending on the circuit order provisioning. In the reference 

configuration the IPFR-EF service delivered 10 digits. 

 

 

 

https://www.business.att.com/products/sip-trunking.html
http://support.avaya.com/
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Figure 1: Reference Configuration 

 

Note – For security purposes, any public IP addresses or PSTN routable phone numbers used 

in the compliance test are not shown in these Application Notes. Instead, public IP addresses 

have been replaced with private addresses and all phone numbers have been replaced with 

numbers that cannot be routed. 
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3.1. Illustrative Configuration Information 

The specific values listed in Table 1 below and in subsequent sections are used in the reference 

configuration described in these Application Notes and are for illustrative purposes only. 

Customers must obtain and use the values based on their own specific configurations. 

  

Note – The Avaya IP Office LAN 2 interface is used on the SIP trunk to AT&T (see Section 

5.2.2) and communicates with the Border Elements (BEs) located in the AT&T IPFR-EF 

network. For security reasons, the IP addresses of the AT&T BEs are not included in this 

document. However, as placeholders in the following configuration sections, the IP addresses 

192.168.200.26 (Avaya IP Office LAN 2 address), and 192.168.38.69 /192.168.37.149 

(AT&T BE IP addresses), are specified. In addition, AT&T DID/DNIS numbers shown in this 

document are examples as well. AT&T Customer Care will provide the actual Border Element 

IP addresses and DID/DNIS numbers as part of the IPFR-EF provisioning process. 

 

Component Illustrative Value in these 

Application Notes 

Avaya IP Office  

Primary Server, LAN2 interface 192.168.200.26 

Primary Server, LAN1 interface 10.64.19.170 

Expansion System, LAN1 Interface 10.5.5.180 

AT&T IPFR-EF Service 

Border Element IP Address 192.168.38.69 & 192.168.37.149 
 

Table 1: Illustrative Values Used in these Application Notes 
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3.2. Call Flows 

To understand how inbound and outbound AT&T IPFR-EF service calls are handled by Avaya 

IP Office, four basic call flows are described in this section. 

 Inbound 

The first call scenario illustrated in the figure below is an inbound AT&T IPFR-EF service 

call that arrives on Avaya IP Office, which in turn routes the call to a hunt group, phone or a 

fax endpoint. 

 

1. A PSTN phone originates a call to an IPFR-EF service number. 

2. The PSTN routes the call to the AT&T IPFR-EF service network. 

3. The AT&T IPFR-EF service routes the call to Avaya IP Office. 

4. Avaya IP Office applies any necessary digit manipulations based upon the DID and 

routes the call to a hunt group, phone or a fax endpoint. 

 

 
 

Figure 2: Inbound AT&T IPFR-EF Call 
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 Outbound 

The second call scenario illustrated in the figure below is an outbound call initiated on Avaya 

IP Office for delivery to AT&T IPFR-EF service. 

 

1. An Avaya IP Office phone or fax endpoint originates a call to an AT&T IPFR-EF 

service number for delivery to PSTN. 

2. Avaya IP Office applies any necessary origination treatment (verifying permissions, 

determining the proper route, selecting the outgoing trunk, etc.) and sends the call to 

the AT&T IPFR-EF service. 

3. The AT&T IPFR-EF service delivers the call to PSTN. 

4. PSTN delivers the call to a phone or fax endpoint. 

 

 
 

Figure 3: Outbound Call to AT&T IPFR-EF 

 

  



 
MAA; Reviewed: 

SPOC 8/11/2020 

 

Solution & Interoperability Test Lab Application Notes 

©2020 Avaya Inc. All Rights Reserved. 

13 of 55 

IPFR-IPO11_1 

 

 Call Forward 

The third call scenario illustrated in the figure below is an inbound AT&T IPFR-EF service 

call destined for an Avaya IP Office station that has set Call Forwarding to an alternate 

destination. Without answering the call, Avaya IP Office redirects the call back to the AT&T 

IPFR-EF service for routing to the alternate destination. 

 

Note – AT&T requires the Diversion header be used when a call is redirected to AT&T IPFR-

EF service (See Section 5.4.4). 

 

1. Same as the first call scenario in Section 3.2.1. 

2. The Avaya IP Office phone has set Call Forward to another AT&T IPFR-EF service 

number; therefore, Avaya IP Office initiates a new call back out to the AT&T IPFR-

EF service network. This new SIP INVITE will contain a Diversion Header. 

3. The AT&T IPFR-EF service places a call to the alternate destination. 

 

Note – The IPFR-EF service offers similar, network based Call Forwarding features that 

allow users to predefine alternate call destinations based on Ring-No-Answer, Busy, Not 

Reachable, or Unconditional criteria. 

 

 
 

Figure 4: Call Forward 
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 Coverage to Voicemail 

The call scenario illustrated in the figure below is an inbound call that is covered to 

Voicemail. In the reference configuration, the Voicemail system used is the embedded Avaya 

IP Office Voicemail. 

1. Same as the first call scenario in Section 3.2.1. 

2. The Avaya IP Office phone does not answer the call, and the call covers to the 

Voicemail Pro. 

 

 
 

Figure 5: Coverage to Avaya IP Office Voicemail  
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4. Equipment and Software Validated 
The following equipment and software was used for the reference configuration described in 

these Application Notes. 

 

Avaya IP Telephony Solution Components 

Equipment Software 

Avaya IP Office Server Edition 

- Avaya IP Office Voicemail Pro 

Release 11.1.0.0.0 Build 237 

Release 11.1.0.0.0 Build 234 

Avaya IP Office 500 V2 Expansion System Release 11.1.0.0.0 Build 237 

Avaya IP Office Manager Release 11.1.0.0.0 Build 237 

Avaya 96x1 Series IP Deskphone (H.323) Release 6.8304 

Avaya 1140E IP Deskphone (SIP) Release 04.04.23.00 

Avaya J169 IP Deskphone (SIP) Release 4.0.4.0.10 

Avaya IX Workplace Client for Windows Release 3.8.5.41.23 

Avaya 9508 Digital Deskphone Release 0.60 

Fax device (Ventafax) Release 7.10 

 

Table 2: Equipment and Software Versions 

 

Note – Compliance Testing is applicable when the tested solution is deployed with a 

standalone IP Office 500 V2, and also when deployed with all configurations of IP Office 

Server Edition. IP Office Server Edition requires an Expansion IP Office 500 V2 to support 

analog or digital endpoints or trunks. 
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5. Avaya IP Office Primary Configuration 

Note – This section describes attributes of the reference configuration but is not meant to be 

prescriptive. In the following sections, only the parameters that are highlighted in bold text 

are applicable to the reference configuration. Other parameter values may or may not match 

based on local configurations. Many forms contain multiple tabs. Only those tabs with 

provisioning related to the reference configuration are discussed. Any other tab/form should 

be considered default values. Additionally, the screen shots referenced in these sections may 

not be the complete form. 

 

Avaya IP Office is configured via the Avaya IP Office Manager program. For more 

information on provisioning Avaya IP Office Manager, consult reference [4].  From the 

Avaya IP Office Manager PC, select Start →Programs →Avaya IP Office →Manager to 

launch the Manager application. Navigate to File → Open Configuration (not shown), select 

the proper Avaya IP Office system from the pop-up window, and log in using the appropriate 

credentials. 
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On Server Edition systems, the Solution View screen will appear, similar to the one shown 

below. All the Avaya IP Office configurable components are shown in the left pane, known as 

the Navigation Pane. Clicking the “plus” sign next to the Primary server system name, e.g., 

IPOSE-Primary, on the navigation pane will expand the menu on this server. In the sample 

configuration, IP users registered to the Primary server. Digital and Analog users are 

configured on the Expansion System. The SIP trunk to AT&T IPFR is configured on the 

Primary server. 

 

 
 

In the screens presented in the following sections, the View menu was configured to show the 

Navigation pane on the left side, the Group pane in the center and the Details pane on the right 

side. These panes will be referenced throughout the rest of this document.  

 

Standard feature configurations that are not directly related to the interfacing with the service 

provider are assumed to be already in place, and they are not part of these Application Notes. 
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5.1. Licensing 

In the reference configuration, IPOSE-Primary was used as the system name of the Primary 

Server and IP500 Expansion was used as the system name of the Expansion System. All 

navigation described in the following sections (e.g., License) appears as submenus underneath 

the system name in the Navigation Pane. 

 

The configuration and features described in these Application Notes require the IP Office 

system to be licensed appropriately. If a desired feature is not enabled or there is insufficient 

capacity, contact an authorized Avaya sales representative. 

 

Navigate to License in the Navigation Pane. In the Details Pane verify that the License Status 

for SIP Trunk Channels is Valid and that the number of Instances is sufficient to support 

the number of channels provisioned for the SIP trunk. 
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5.2. System Settings 

This section illustrates the configuration of system settings. Select System in the Navigation 

pane to configure these settings. The subsection order corresponds to a left to right navigation 

of the tabs in the Details pane for System settings. For all the following configuration 

sections, the OK button (not shown) must be selected in order for any changes to be saved. 

 

 LAN 1 Tab 

In the reference configuration, LAN1 was used to connect the Avaya IP Office Primary server 

to the CPE network (see Section 3). 

5.2.1.1  LAN 1 – LAN Settings Tab 

To view or configure the LAN 1 IP address, select the LAN 1 → LAN Settings tab, and enter 

the following: 

• IP Address: Set to 10.64.19.170 as used in the reference configuration.  

• IP Mask: Set to 255.255.255.0 as used in the reference configuration 

• Click the OK button (not shown). 
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5.2.1.2 LAN 1 - VoIP Tab 

Select the LAN1 → VoIP tab as shown in the following screen. The following settings were 

used in the reference configuration: 

• The H323 Gatekeeper Enable box is checked to allow the use of Avaya IP 

Telephones using the H.323 protocol, such as the Avaya 96x1-Series Deskphones 

used in the reference configuration. 

• The H.323 Signaling over TLS should be set based on customer needs. In the 

reference configuration it is set to Preferred. 

• The SIP Registrar Enable box is checked to allow Avaya J100-Series Deskphones, 

Avaya 1100-Series Deskphones and Avaya IX™ Workplace usage. 

• The Domain Name and SIP Registrar FQDN used in the reference configuration is 

silipose.customer.com. 

• Set the Layer 4 Protocol section based on customer needs. In the reference 

configuration TCP/5055 and TLS/5056 is configured. 

• Let all other values default. 

• Click the OK button (not shown). 
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5.2.1.3 LAN 1 - Network Topology Tab 

Select the LAN1 → Network Topology tab as shown in the following screen, and enter the 

following: 

• Public IP Address: The 0.0.0.0 default value is used. This means Avaya IP Office 

will use the LAN1 IP address specified on the LAN1 LAN Settings tab described 

above (10.64.19.170). 

• Firewall/NAT Type is set to Unknown in the reference configuration. Note that the 

Firewall/NAT Type parameter may need to be set differently, depending on the type 

of firewall or Network Address Translation device used at the customer premise. 

• Click the OK button (not shown). 

 

 

 LAN 2 Tab 

The LAN 2 interface is used for the SIP trunk connection to AT&T. 

5.2.2.1 LAN 2 - LAN Settings Tab 

• IP Address: In the reference configuration the IP Office public address is 

192.168.200.26. 

• IP Mask: In the reference configuration the IP Office public address subnet mask is 

255.255.255.248. 

• Other parameters on this screen are set to the defaults. 
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5.2.2.2 LAN 2 - VoIP Tab 

• Select the SIP Trunks Enabled option. 

• RTP Port Number Range: The AT&T IPFR service requires that the RTP use the 

port range 16384 to 32767. 

o 16384 entered in the Port Range (Minimum) field. 

o 32766 entered in the Port Range (Maximum) field, as this field requires even 

numbers. 

 

 
 

• To prevent possible issues with network firewalls closing idle RTP channels, it is 

recommended that RTP Keepalives are enabled. Scrolling down to the bottom of the 

form, enter the following: 

o Scope: Select RTP-RTCP 

o Periodic Timeout: Enter 30 

o Initial keepalives: Select Enabled 

• Other parameters on this screen are set to the defaults. 

• Click the OK button (not shown). 
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5.2.2.3 LAN 2 - Network Topology Tab 

In the reference configuration, it was not necessary to configure the Network Topology tab for 

the purposes of SIP trunking.  If a NAT is used between Avaya IP Office and AT&T Border 

Element, then the SIP Line Use Network Topology Info field in Section 5.4.3 should be set to 

the LAN2 interface used by the trunk and the Network Topology tab needs to be configured 

with the details of the NAT device. The Network Topology tab is summarized here for 

completeness. 

• The Firewall/NAT Type is set to Open Internet in the reference configuration. Note 

that the Firewall/NAT Type parameter may need to be set differently, depending on 

the type of firewall or Network Address Translation device used at the customer site. 

• Binding Refresh Time: This field specifies how often IP Office will issue a SIP 

OPTIONS message to check the SIP trunk connection status to AT&T. In the 

reference configuration, 60 is specified. 

• The Public IP Address and Public Port fields are not used for the SIP trunk 

connection to AT&T. Click the OK button (not shown). 

 

 

 Voicemail Settings 

As described in Section 3, Voicemail Pro was used in the reference configuration. 

• Set Voicemail Type to Voicemail Lite/Pro. 

• Set Voicemail IP Address to the IP address of the server hosting voicemail. In the 

reference configuration, this is 10.64.19.170. 

• Other parameters on this screen are default. Click the OK button (not shown). 
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 System Telephony Settings 

To view or change telephony settings, select the Telephony tab and Telephony sub-tab as 

shown in the following screen. The settings presented here simply illustrate the values used in 

the reference configuration and are not intended to be prescriptive. 

• Uncheck the Inhibit Off-Switch Forward/Transfer box. This is so that call 

forwarding and call transfer to PSTN destinations via the AT&T IPFR-EF service can 

be tested. 

• Set the Companding Law parameters are set to U-Law as is typical in North 

America. 

• Default values are used in the other fields. 

• Click the OK button (not shown). 
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 System VoIP Settings 

To view or change system codec settings, select the VoIP tab and VoIP sub-tab as shown on 

the screen below. On the left, observe the list of Available Codecs. By selecting codecs in 

this column, they will appear in the Default Codec Selection → Unused column. Codecs 

may be selected from the Unused list and moved to the Selected column by use of the >>> 

button, thereby making the selected codecs available in other screens where codec 

configuration may be performed (e.g., Sip Lines and Extensions). The up and down arrow 

buttons are used to order the selected codecs. By default, all IP (SIP and H.323) lines and 

extensions will assume the system default Selected codec list, unless configured otherwise for 

the specific line or extension. 

• In the RFC2833 Default Payload setting field, specify 100, which is the 

recommended value for AT&T. 

• Click the OK button (not shown). 
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 System VoIP Security 

To view or configure the media encryption settings, select the VoIP → VoIP Security tab on 

the Details pane. For the compliance test, SRTP was used internal to the enterprise wherever 

possible.  

• Set the Media drop-down menu to Preferred to have IP Office attempt use SRTP for 

devices that support it, and fall back to RTP for devices that do not support encryption.  

• Under Media Security Options, select RTP for the Encryptions and Authentication 

fields.  

• Under Crypto Suites, select SRTP_AES_CM_128_SHA1_80.  

• Click OK to commit (not shown). 

 

 

5.3. IP Route 

In the reference configuration, the Primary server LAN1 port is physically connected to the 

local area network switch at the IP Office customer site. The default gateway for this network 

is 10.64.19.1. The IP Office LAN2 port is connected to the AT&T network and has a default 

gateway of 192.168.200.25. To add an IP Route in the Primary server, right-click IP Route 

from the Navigation pane, and select New (not shown). To view or edit an existing route, 

select IP Route from the Navigation pane, and select the appropriate route from the Group 

pane. The following screen shows the Details pane with the relevant route using LAN2 as 

Destination. 
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5.4. SIP Line 

The following sections describe the configuration of a SIP Line. The SIP Line terminates the 

CPE end of the SIP trunk to the AT&T IPFR-EF service. 

 

The recommended method for creating/configuring a SIP Line is to use the template 

associated with the provisioning described in these Application Notes. The template is an .xml 

file that can be used by Avaya IP Office Manager to create a new SIP Line for SIP trunking 

with the AT&T IPFR-EF service. Follow the steps in Section 5.4.1 to create a SIP Trunk from 

the template. 

 

Some items relevant to a specific customer environment are not included in the template or 

may need to be updated after the SIP Line is created. Examples include the following: 

• IP addresses 

• SIP Credentials (if applicable) 

• SIP URI entries 

• Setting of the Use Network Topology Info field on the Transport tab. 

 

Therefore, it is important that the SIP Line configuration be reviewed and updated if 

necessary, after the SIP Line is created via the template. The resulting SIP Line data can be 

verified against the manual configuration as shown in Sections 5.4.2 – 5.4.6. 

 

In addition, the following SIP Line settings are not supported on Basic Edition: 

• SIL Line – Originator number for forwarded and twinning calls 

• Transport – Second Explicit DNS Server 

• SIP Credentials – Registration Requirements 

• SIP Advanced Engineering 

 

Alternatively, a SIP Line can be created manually. To do so, right-click Line in the 

Navigation pane and select New → SIP Line. Then, follow the steps outlined in Sections 

5.4.2 – 5.4.6. 
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 Importing a SIP Line Template 

Note – DevConnect generated SIP Line templates are always exported in an XML format. 

These XML templates do not include sensitive customer specific information and are 

therefore suitable for distribution. The XML format templates can be used to create SIP 

trunks on both IP Office Standard Edition (IP500 V2) and IP Office Server Edition 

systems. Alternatively, binary templates may be generated. However, binary templates 

include all the configuration parameters of the Trunk, including sensitive customer 

specific information. Therefore, binary templates should only be used for cloning trunks 

within a specific customer’s environment. 

 

Copy a previously created template file to the computer where IP Office Manager is installed. 

To create the SIP Trunk from the template, right-click on Line in the Navigation Pane, then 

navigate to New →New from Template. Select Open from file.  

 

 
 

Navigate to the directory where the template was copied on the local computer (e.g., \temp) and 

select it. Click Open (not shown). 

 

 
 

The new SIP Line is created, and it will appear on the Navigation pane (e.g., SIP Line 2). The 

resulting SIP Line data can be verified against the manual configuration shown in Sections 

5.4.2 to 5.4.6. 
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 SIP Line – SIP Line tab 

The SIP Line tab in the Details pane is shown below for Line Number 2, used for the SIP 

Trunk to AT&T. Note, if no SIP Line exists, right click on the Line item in the Navigation 

pane and select New → SIP Line (not shown). In the reference configuration, SIP Line 2 was 

created. The SIP Line form is completed as follows: 

• ITSP Domain Name: Use the default <blank> to have IP Office send the ITSP Proxy 

Address as the domain name. 

• Local Domain Name: Set to the public IP address of the Avaya IP Office LAN2 SIP 

trunking interface (e.g., 192.168.200.26). 

• In Service and Check OOS: These boxes are checked (default). Note that to check the 

Out Of Service (OOS) condition, IP Office will use the SIP OPTIONS method to 

periodically check the SIP Line. The time between SIP OPTIONS sent by IP Office is 

determined by the Binding Refresh Time for LAN2, as shown in Section 5.2.2. 

• Refresh Method: Set to Re-Invite, as AT&T does not support UPDATE.  

• Set Timer (sec) to 1800 seconds. This field specifies the session expiry time. With this 

value, a session refresh message is sent every 15 minutes, at the half way point of the 

expiry time. 

• Incoming Supervised Refer: Set this field to Always to enable Avaya IP Office to 

accept REFER sent by the network during a transfer scenario. 

• Outgoing Supervised Refer: Set this field to Always to enable Avaya IP Office to 

use REFER (with Replaces) for station-initiated call transfer scenarios back to PSTN. 

• Outgoing Blind Refer: Optional. Enable this option to support Refer (without 

Replaces) for “Blind” (unattended) transfers (e.g., transfer-to party is still ringing 

when the transfer operation is completed). If this feature is not enabled, then Refer 

(with Replaces) will be used. Note – This feature is only supported with certain SIP 

telephones and Voicemail call flows. 

• Use the default values for the other fields. 

• Click OK (not shown). 
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 SIP Line - Transport tab 

Select the SIP Line → Transport tab and configure the following: 

•  ITSP Proxy Address: Set to the AT&T Border Element IP address (e.g., 

192.168.38.69).  

• Layer 4 Protocol:  Set to UDP. 

• Send Port: Set to 5060 (default). 

• Listen Port: Set to 5060 (default). 

• Use Network Topology Info: Set to None since no NAT was used in the test 

configuration. 

• Verify Calls Route via Registrar: Enabled (default). 

• Click OK (not shown). 

 

 
 

Note – See Addendum 1 in Section 11 for a configuration example and considerations when 

using multiple AT&T Border Elements. 
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 SIP Line – Call Details tab 

Select the SIP Line → Call Details tab. 

 

 
 

To add a new SIP URI, click the Add… button. A New URI window will open. Configure the 

following: 

• Incoming Group:  Set to 2 (SIP Line 2). This value references the table created with 

Incoming Call Routes in Section 5.8. 

• Max Sessions: In the reference configuration this was set to 10. This sets the 

maximum number of simultaneous calls that can use the URI before Avaya IP Office 

returns busy to any further calls. 

• Outgoing Group: Set to 2 (SIP Line 2). This will be used for routing outbound calls 

to AT&T via the ARS configuration (Section 5.9). 

• Verify Diversion Header is checked. 

• Local URI, Contact, and Diversion Header fields for the Display and Content 

columns: Set these fields to Auto. With this configuration, information in the 

Incoming Call Route (Section 5.8) is used determine what call is accepted on the SIP 

Line. The Incoming Call Route for individual users will also be used to populate the 

SIP From and Contact headers for outbound calls. 

• Field meaning section: Set to the values shown in the screenshot below.  

• Click OK. 
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In the reference configuration, the single SIP URI shown was sufficient to allow incoming 

calls for AT&T DID numbers destined for specific IP Office users, hunt groups or short 

codes. 

 SIP Line - VoIP tab 

Select the SIP Line → VoIP tab.  

• The Codec Selection drop-down box → System Default will list all available codecs. 

In the reference configuration, Custom was selected with G729(a) 8K CS-ACELP 

and G.711 ULAW 64K specified. This causes Avaya IP Office to include these 

codecs in the Session Description Protocol (SDP) offer, and in the order specified. 

Note that in the reference configuration G.729A is set as the preferred codec on the 

SIP trunk to the AT&T IPFR-EF network. During testing, the IP Office configuration 

was varied such that G.711MU was the preferred or only codec listed, and G.711MU 

calls were also successfully verified. 

• T.38 fax was used in the reference configuration. Set the Fax Transport Support 

drop-down menu to T.38. G.711 fax also worked in the reference configuration (T.38 

option disabled); however, T.38 is the preferred method. 

• Set the DTMF Support field to RFC2833/RFC4733. This directs IP Office to send 

DTMF tones using RTP events messages as defined in RFC2833. 

• The Re-invite Supported parameter can be checked to allow for codec re-negotiation 

in cases where the target of an incoming call or transfer does not support the codec 

originally negotiated on the trunk. 

• Click OK (not shown). 
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 SIP Line – SIP Advanced Tab 

Select the SIP Advanced tab. Set the parameters as shown below:  

• Check the box for Use PAI for Privacy. By default, Avaya IP Office will use the PPI 

(P-Preferred-Identity) header for signaling user information when privacy is invoked. 

However, AT&T utilizes the PAI (P-Asserted-Identity) header for privacy. Therefore, 

Avaya IP Office is configured to use the PAI header to pass the calling party information 

for authentication and billing when privacy is used. 

• Select Indicate HOLD. IP Office can be configured to signal when a call is placed on 

hold by sending an INVITE with media attribute “sendonly”. AT&T in turn will 

respond with media attribute “recvonly” and will stop sending RTP media for the 

duration the call is on hold. When the call is taken off of hold, IP Office will send 

another INVITE with media attribute “sendrecv” indicating to AT&T to start sending 

RTP again. 

• Select Emulate NOTIFY for Refer. The AT&T IPFR-EF service does not support 

NOTIFY. Some Avaya endpoints (e.g., Avaya 1140E Deskphone) require receipt of a 

NOTIFY when Refer based call transfers are performed. This option will send a 

NOTIFY to these endpoints. 

• By default, Avaya IP Office sends Refer in addition to Diversion header for call 

forward scenarios. However, AT&T only requires Diversion header. Therefore, in the 

reference configuration the No Refer if using Diversion was selected. 

• Default values may be used for all other parameters. 

• Click OK to commit (not shown). 
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5.5. IP Office Line 

IP Office Lines are automatically created on each server when a Secondary server or 

Expansion System is added to the solution. To edit an existing IP Office Line, select Line in 

the Navigation pane, and select the appropriate Line to be configured in the Group pane. 

Below is the IP Office Line to the Expansion System. 

 

 
 

The screen below shows the IP Office Line, VoIP Settings tab. In the reference configuration a 

fax machine is connected to one of the analog ports on the Expansion System. Fax Transport 

Support is set to T.38. The Media Security is set to Same as System (Preferred) to have IP 

Office use the system setting for media security set in Section 5.2.6 to encrypted RTP. Default 

values were used for all other parameters. 
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5.6. Short Codes 

Avaya IP Office provides predefined Short Codes; however new Short Codes may be defined 

to match number strings to an action. To add a Short Code, right click on Short Code in the 

Navigation pane, and select New (not shown). To edit an existing Short Code, click Short 

Code in the Navigation pane, and the Short Code to be configured in the Group pane. 

 

In the screen shown below, the Short Code 9N is illustrated. This Short Code will allow an 

Avaya IP Office user to dial the digit 9 followed by any telephone number, symbolized by the 

letter N, to reach the SIP Line to AT&T. However, Avaya IP Office will first consult the ARS 

table defined in Section 5.9. The variable N can be any number string. 

• The Code parameter is set to 9N. 

• The Feature parameter is set to Dial. 

• The Telephone Number parameter is set to N. 

• The Line Group ID parameter is set to 62: ATT-IPFR, which directs the call to 

ARS (see Section 5.9). 

• Click the OK button (not shown). 
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5.7. Users, Extensions, and Hunt Groups 

In this section, examples of IP Office Users, Extensions, and Groups will be illustrated. In the 

interests of brevity, not all users and extensions shown in Figure 1 will be presented, since the 

configuration can be easily extrapolated to other users. To add a User, right click on User in 

the Navigation pane, and select New. To edit an existing User, select User in the Navigation 

pane, and select the appropriate user to be configured in the Group pane. 

 SIP User 

The following screen shows the User tab for user 6241. As shown in Figure 1, this user 

corresponds to the Avaya J169 SIP endpoint. 
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The following screen shows the Extension information for this user. To view, select 

Extension from the Navigation pane, and the appropriate extension from the Group pane. 

 

 
 

The following screen shows the VoIP tab for the extension. The IP Address field may be left 

blank. Check the Reserve Avaya IP endpoint license box. The Codec Selection parameter 

may retain the default setting “System Default” to follow the system configuration shown in 

Section 5.2.5. The Media Security parameter may also retain the default setting “Same as 

System (Preferred)” to follow the system configuring shown in Section 5.2.5. 
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 Hunt Groups 

During the verification of these Application Notes, users could also receive incoming calls as 

members of a hunt group. To configure a new hunt group, right-click Group from the 

Navigation pane, and select New. To view or edit an existing hunt group, select Group from 

the Navigation pane, and the appropriate hunt group from the Group pane. 

 

The following screen shows the Group tab for hunt group 401. The telephone extensions in 

the User List are rung based the extension that has been unused for the longest period, due to 

the Ring Mode setting “Longest Waiting” (i.e., “longest waiting”, most idle user receives 

next call). Click the Edit button to change the User List. 
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5.8.  Incoming Call Routes 

Each Incoming Call Route will map a specific AT&T DNIS number to a destination User, 

Hunt Group, or Short Code, on Avaya IP Office. To add an incoming call route, right click on 

Incoming Call Route in the Navigation pane and select New (not shown). To edit an existing 

incoming call route, select Incoming Call Route in the Navigation pane, and the appropriate 

incoming call route to be configured in the Group pane. 

 

Note – When the destination is a user’s extension, the Incoming Number can be used to 

construct the From and Contact headers in place of the extension number in the outgoing SIP 

INVITE message for the user. See Section 5.4.4. 

 

In the screen shown below, the incoming call route for Incoming Number → 3035559322 is 

illustrated. The Line Group ID is set to 2, matching the Incoming Group field configured in 

the Call Details tab for the SIP Trunk to AT&T in Section 5.4.4. 

 

 
 

Select the Destinations tab. From the Destination drop-down menu, select the extension to 

receive the call when AT&T delivers DNIS digits 3035559322. In the reference configuration 

DNIS digits 3035559322 is associated with user 6322. 

 

 
 

Repeat this process to route all AT&T DNIS numbers to additional telephone, as well as other 

Avaya IP Office destinations (Hunt Group, Voicemail, Short Codes, etc.). Incoming Call 

Routes for other direct mappings of DID numbers to IP Office users are omitted here but can 

be configured in the same fashion. 
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5.9. Automatic Route Selection (ARS) 

While detailed coverage of ARS is beyond the scope of these Application Notes, this section 

includes basic ARS screen illustrations and considerations, including alternate routing should 

the SIP Line be out of service or temporarily not responding. As described in Section 5.6, 

Short Code 9N was defined for ARS access. Therefore, outbound calls via ARS are dialed as 

9 plus the number. ARS will strip off the 9 and process the call based on the remaining digits. 

 

• To add a new ARS route, right-click ARS in the Navigation pane, and select New (not 

shown). To view or edit an existing ARS route, select ARS in the Navigation pane, 

and select the appropriate route name in the Group pane (e.g., 62: ATT-IPFR). 

 

The following screen shows an example ARS configuration for the route ATT-IPFR (ARS 

Route ID 62). The list of codes defined below is simply an example and not intended to be 

prescriptive. Other dialing codes may be appropriate for different customer networks. 

 

 
 

• To add a new ARS table entry, click on the Add button. To change an existing entry, 

click on the Edit button (note that the Edit button is grayed out until an entry is 

selected). 
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The example below shows the entry for 11 (1+10) digit calls. 

 

 
 

• Set Code to 1xxxxxxxxxx  

This means any dialed string starting with a 1, and 11 digits in total will be routed to 

the specified Line Group.  

•  Feature = Dial  

• Telephone Number = N  

With this setting the leading 1 will be excluded, and only the remaining 10 digits will 

be sent to AT&T. 

• Line Group ID = 2 (SIP Line 2).  
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5.10. Outbound Calling Party Information 

Following to the SIP URI configuration on Section 5.4.4, Avaya IP Office will use the 

information on the Incoming Number field on the Incoming Call Routes (Section 5.8) to 

populate the From and Contact headers on outbound calls from the IP Office users. These 

headers are used by the service provider to deliver Caller ID information to the receiving end 

of the call. 

 

There are cases where the IP Office user may not be associated with an Incoming Call Route.  

In other situations, it may be desired to send the same outbound caller ID for all the users in 

the enterprise. Short Codes can be created to construct the From and Contact headers in the 

outgoing SIP INVITE message. 

 

 Short Code - User 

In cases where a user does not have an associated Incoming Call Route with a 10-digit 

number assigned to it, a Short Code can be created for that user to set the outbound caller ID.  

 

To set a Short Code for an existing user, select User in the Navigation pane, and select the 

appropriate user to be configured in the Group pane. Select the Short Code tab on the Details 

pane and click Add (not shown). 

 

The following screen shows the Short Codes tab for user 6240. This user does not have an 

associated Incoming Call Route.  

 

 
 

• Set Code to 9N 

• In the example, the Telephone Number is set to “Ns4695554878”. The number after  

the “s” will be sent on the From and Contact headers of the SIP INVITE on outbound 

calls from this user. 

• Feature = Dial 

• Line Group ID = 62, the ARS route to be used for AT&T. 
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 Short Code – ARS 

There may be other specific cases when it is preferred to send the same caller ID on outbound 

calls for all the users in the enterprise, for example, the published main number for the 

location.  

 

Short Code entries on the ARS table (Section 5.9) can be created or edited, to modify the 

From and Contact headers in the outgoing SIP INVITE messages for all outbound calls.  

 

On the screen below, an existing ARS Short Code entry was modified. The Telephone 

Number is set to “Ns4695554000”. The number after the “s” will be sent on the From and 

Contact headers of the SIP INVITE on outbound calls from all users in the Avaya IP Office 

using this ARS route. 
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5.11. Saving Configuration Changes to Avaya IP Office 

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the 

configuration performed in the preceding sections. 

 

The following will appear, with either Merge or Reboot selected for the Change Mode, 

based on the nature of the configuration changes made since the last save. Note that clicking 

OK may cause a service disruption.  

 

Click OK to execute the save. 

 

 
 

Note that the active configuration may be saved to a file at any time by selecting File → Save 

Configuration As. 
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6. Avaya IP Office Expansion Configuration 
Navigate to File → Open Configuration (not shown), select the proper Avaya IP Office 

system from the pop-up window, and log in using the appropriate credentials. Clicking the 

“plus” sign next to IP500 Expansion on the left navigation pane will expand the menu on this 

server. 

 

 

6.1. Expansion System - Physical Hardware 

In the sample configuration, the IP500 V2 Expansion System contained a PHONE8 analog 

card and a COMBO6210 card, for the support of analog and digital stations. Also included is 

a VCM64 (Voice Compression Module). Both the VCM64 and the COMBO6210 cards 

provide voice compression channels to the control unit. Voice compression channels are 

needed to support VoIP calls, including IP extensions and or IP trunks. 
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6.2. LAN Settings 

In the sample configuration, LAN 1 is used to connect the Expansion System to the enterprise 

network. To view or configure the LAN 1 IP address, select the LAN 1 → LAN Settings tab, 

and enter the following: 

• IP Address: Set to 10.5.5.180 as used in the reference configuration.  

• IP Mask: Set to 255.255.255.0 as used in the reference configuration 

• Click the OK button (not shown). 

 

 
 
Defaults were used on the VoIP and Network Topology tabs (not shown). 

6.3. Expansion System - IP Route 

Configuration is done similar to the Primary server, as shown in Section 5.3. Configure a 

default route for the Expansion server. The default gateway in the reference configuration is 

10.5.5.2. 
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6.4. Expansion System - IP Office Line 

The IP Office Lines are automatically created on each server when the Expansion System is 

added to the solution. Below is the IP Office Line (Line Number 17) to the Primary server. 

 

 
 

In the reference configuration, a fax machine is connected to one of the analog ports on the 

Expansion System. To accommodate T.38 fax, select the VoIP Settings tab and set Fax 

Transport Support to T38 Fallback. The Media Security drop-down menu is set to “Same 

as System (Preferred)” to have IP Office use the system setting for media security set in 

Section 5.2.6 to encrypted RTP. 
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Select the T38 Fax tab. The Use Default Values box is unchecked, and the T38 Fax Version 

is set to 0. All other values are left at default. 

 

 

6.5. Expansion System - Short Codes 

Similar to the configuration of the Primary server in Section 5.6, create a Short Code to 

access ARS. In the reference configuration, the Line Group ID is set to an ARS route 

illustrated in the next section. 
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6.6. Expansion System - Automatic Route Selection – ARS 

The following screen shows an example ARS configuration for the route named “To-

Primary” on the Expansion System. The Line Group ID is set to “99999” matching the 

number of the Outgoing Group configured on the IP Office Line 17 to the Primary server 

(Section 6.4). 

 

 

6.7. Save IP Office Expansion System Configuration 

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the 

configuration performed in the preceding sections. 

 

The following will appear, with either Merge or Reboot selected, based on the nature of the 

configuration changes made since the last save. Note that clicking OK may cause a service 

disruption. Click OK to proceed. 
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7. AT&T IP Flexible Reach – Enhanced Features 
Configuration 

AT&T provides the IPFR-EF service border element IP address, the access DID numbers, and 

the associated DNIS digits used in the reference configuration. In addition, the AT&T IPFR-

EF features, and their associated access numbers, are also assigned by AT&T. 

8. Verification Steps 
The following procedures may be used to verify the Avaya IP Office Release 11.1 with the 

AT&T IP Flexible Reach - Enhanced Features service configuration. 

8.1. AT&T IP Flexible Reach – Enhanced Features 

The following scenarios may be executed to verify Avaya IP Office and the AT&T IPFR-EF 

service interoperability: 

• Place inbound and outbound calls, answer the calls, and verify that two-way talk path 

exists. Verify that the calls remain stable for several minutes and disconnects properly. 

• Verify basic call functions such as hold, transfer, and conference. 

• Verify the use of DTMF signaling. 

• Place an inbound call to a telephone, but do not answer the call. Verify that the call 

covers to voicemail (e.g., Avaya IP Office Voicemail Pro). Retrieve the message either 

locally or from PSTN. 

• Using the appropriate IPFR-EF access numbers and codes, verify that the following 

features are successful: 

o Network based Simultaneous Ring – The “primary” and “secondary” endpoints 

ring, and either may be answered. 

o   Network based Sequential Ring (Locate Me) – Verify that after the “primary” 

endpoint rings for the designated time, the “secondary” endpoint rings and may 

be answered. 

o  Network based Call Forwarding Always (CFA/CFU), Network based Call 

Forwarding Ring No Answer (CF-RNA), Network based Call Forwarding 

Busy (CF-Busy), Network based Call Forwarding Not Reachable (CF-NR) – 

Verify that based on each feature criteria, calls are successfully redirected and 

may be answered. 

• Inbound / Outbound fax using T38 or G.711. 

• SIP OPTIONS monitoring of the health of the SIP trunk.  

• Incoming and outgoing calls using the G.729 (A or B) and G.711 ULAW codecs. 

• Avaya IP Office Mobile twinning to a mobile phone when the associated Avaya IP 

Office extension is called, as well as Mobility features such as Mobile Callback and 

Mobile Call Control may also be verified. 
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8.2. Avaya IP Office Release 11.1 

The following items may be used to analyze/troubleshoot Avaya IP Office operations. 

 System Status Application 

The Avaya IP Office System Status application can be used to verify the service state of the 

SIP line. From the IP Office Manager application, select File → Advanced → System Status.  

Under Control Unit IP Address select the IP address of the IP Office system under 

verification. Log in using the appropriate credentials. 

 

 
 

After logging in, select Trunks → Line: 2 from the left navigation menu. (SIP Line 2 is 

configured in Section 5.4). On the Status tab in the right pane, verify that the Current State 

is Idle for each channel (assuming no active calls at present time). 
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In the lower left, the Trace All button may be pressed to display tracing information as calls 

are made using this SIP Line. The Ping button can be used to ping the other end of the SIP 

trunk (e.g., the AT&T Border Controller; however, the AT&T Border Controller may not be 

configured to respond to pings). 

 System Monitor Application 

The Avaya IP Office Monitor application can be used to monitor and troubleshoot signaling 

messaging on the SIP trunk. Launch the application from Start → Programs → IP Office → 

Monitor on the PC where IP Office Manager was installed. Click the Select Unit icon on the 

taskbar and Select the IP address of the IP Office system under verification.  
 

 
 

Clicking the Trace Options icon on the taskbar and selecting the SIP tab allows modifying 

the threshold used for capturing events, types of packets to be captured, filters, etc. 

Additionally, the color used to represent the packets in the trace can be customized by right 

clicking on the type of packet and selecting to the desired color. 
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9. Conclusion 
As illustrated in these Application Notes, Avaya IP Office R11.1 can be configured to 

interoperate successfully with the AT&T IP Flexible Reach - Enhanced Features service using 

AVPN or ADI/PNT transport connections, within the limitations described in Section 2.2. 

 

This solution provides users of Avaya IP Office R11.1 the ability to support inbound and 

outbound calls utilizing an AT&T IPFR-EF SIP trunk service connection, via AVPN or 

ADI/PNT transport, using the platform and service features listed in Section 2.1. 

 

The reference configuration shown in these Application Notes is representative of a basic 

enterprise customer configuration and is intended to provide configuration guidance to 

supplement other Avaya product documentation. It is based upon formal interoperability 

compliance testing as part of the Avaya DevConnect Service Provider program. 

10. Additional References 
Avaya: 

Avaya product documentation is available at http://support.avaya.com  

 

[1] IP Office, Deploying IP Office Server Edition Solution, Release 11.1, Issue 14, April 2020 

[2] IP Office™ Platform 11.1, Deploying Avaya IP Office Servers as Virtual Machines, April 

2020 

[3] IP Office™ Platform 11.1, Deploying an IP500 V2 IP Office Essential Edition System, 

April 2020. 

[4] Administering Avaya IP Office™  Platform with Manager, Release 11.1, Issue 1, April 

2020. 

[5] Administering Avaya IP Office™ Platform with Web Manager, Release 11.1, Issue 1, 

April 2020. 

[6] Planning for and Administering Avaya IX™ Workplace Client for Android, iOS, Mac and 

Windows, Release 3.8, Issue 1, March 2020 

[7] Using Avaya IX™ Workplace Client for Android, iOS, Mac and Windows, Release 3.8,  

Issue 1, March 2020. 

 

Additional Avaya IP Office information can be found at: 

https://ipofficekb.avaya.com/ 

 

AT&T IPFR-EF Service: 

 

[8] Information on the AT&T IP Flexible Reach service can be found here: 

https://www.business.att.com/products/sip-trunking.html. 
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https://www.business.att.com/products/sip-trunking.html
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11. Addendum 1 – Multiple AT&T Border Elements 
AT&T may provide multiple network border elements for redundancy purposes. Avaya IP 

Office can be provisioned to support this redundant configuration. 

 

Given two AT&T border elements 192.168.38.69 (primary) and 192.168.37.149 (secondary), 

the SIP Line (Line 2) defined in Section 5.4, can be modified to include the secondary Border 

Element. 

 

1. Navigate to Line → 2 → Transport Tab and populate the ITSP Proxy Address field 

with the primary address, followed by the secondary address, separated by a space. 

 

 
 

2. Click OK (not shown), and save the configuration as shown in Section 0. 

 

When completed, Avaya IP Office will send OPTIONS to both of the AT&T Border 

Elements, as well as respond to OPTIONS received from these addresses. 

 

When only the IP addresses are specified, Avaya IP Office will send all outbound calls to the 

first address specified (192.168.38.69). If the OPTIONS fail for the primary connection, then 

Avaya IP Office will use the second address (192.168.37.149) for all calls. 

 

However, “weights” may be added to those addresses so that Avaya IP Office can alternate 

calls between them. The resulting outbound calls will be distributed based on the weight 

differential. For example, a setting of 192.168.38.69w1 192.168.37.149w1, will result in a 

“round-robin” behavior, while a setting of 192.168.38.69w2 192.168.37.149w1, will result in 

a “two-to-one” behavior. 

 

Note – Up to four IP addresses may be specified in the ITSP Proxy Address field. 
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