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Abstract 
 

 

These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) trunking between Telnyx Mission Control SIP Trunking Service and Avaya IP Office 

Server Edition R11.1. 

 

Telnyx Mission Control SIP Trunking provides PSTN access via a SIP Trunk connected to the 

Telnyx Voice over Internet Protocol (VoIP) network as an alternative to legacy analogue or 

digital trunks. Telnyx is a member of the Avaya DevConnect Service Provider program. 

 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as the observations noted in Section 2.2, to ensure that their own use cases 

are adequately covered by this scope and results. 
 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions. Testing was conducted via the DevConnect 

Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) trunking between Telnyx Mission Control SIP Trunking (hereafter referred as Telnyx SIP 

Trunk) and Avaya IP Office Server Edition R11.1. 

 

Avaya IP Office is a versatile communications solution that combines the reliability and ease of 

a traditional telephony system with the applications and advantages of an IP telephony solution. 

This converged communications solution can help businesses reduce costs, increase 

productivity, and improve customer service. 

 

Customers using this Avaya SIP-enabled solution with Telnyx’s SIP Trunk are able to place and 

receive PSTN calls via a dedicated Internet connection and the SIP protocol. This converged 

network solution is an alternative to traditional PSTN trunks. This approach generally results in 

lower cost for the enterprise customer. 

2. General Test Approach and Test Results  
The general test approach was to configure a simulated enterprise site using Avaya IP Office 

Server Edition R11.1 to connect to the Telnyx SIP Trunk. This configuration (shown in Figure 

1) was used to exercise the features and functionality listed in Section 2.1. 

 

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The 

jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent 

to the interoperability of the tested products and their functionalities. DevConnect Compliance 

Testing is not intended to substitute full product performance or feature testing performed by 

DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or 

completeness of a DevConnect member’s solution. 

 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products. The testing referenced in these DevConnect 

Application Notes included the enablement of supported encryption capabilities in the Avaya 

products. Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

 

Support for these security and encryption capabilities in any non-Avaya solution component is 

the responsibility of each individual vendor. Readers should consult the appropriate vendor-

supplied product documentation for more information regarding those products. 
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2.1. Interoperability Compliance Testing 

To verify SIP trunking interoperability the following features and functionality were exercised 

during the interoperability compliance test: 

• Incoming PSTN calls to various phone types including H.323, SIP, Digital and Analog 

telephones at the enterprise. 

• All inbound PSTN calls were routed to the enterprise across the SIP trunk from the 

Service Provider. 

• Outgoing PSTN calls from various phone types including H.323, SIP, Digital, and 

Analog telephones at the enterprise. 

• All outbound PSTN calls were routed from the enterprise across the SIP trunk to the 

Service Provider. 

• Incoming and Outgoing PSTN calls to/from Avaya Workplace Client for Windows soft 

phone. 

• Calls using the G.711Mu and G.729 codecs. 

• Fax calls to/from a group 3 fax machine to a PSTN-connected fax machine using T.38 

Standard  transmissions.  

• DTMF transmission using RFC 2833 with successful Voice Mail/Vector navigation for 

inbound and outbound calls. 

• Various call types including: local, long distance, international, toll free (outbound) and 

directory assistance. 

• Caller ID presentation and Caller ID restriction. 

• User features such as hold and resume, call mute, transfer, and conference. 

• Off-net call forwarding and mobile twinning. 

• Inbound and Outbound Toll Free. 

• E911 Emergency Service. 
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2.2. Test Results 

Interoperability testing of the test configuration was completed with successful results for 

Telnyx’s SIP Trunk service with the following observations: 

• Fax support: Fax calls using the T.38 protocol worked properly during the compliance 

test. G.711 pass-through fax was also tested, but it behaved unreliably. The issue related to 

G.711 pass-through fax failing during the compliance test may be related to the 

unpredictability of G.711 pass-through techniques, which only works well on networks 

with very few hops and with limited end-to-end delay. 

• SIP OPTION Messages: During the compliance test Telnyx did not send SIP OPTION 

messages to Avaya IP Office, IP Office did send SIP OPTION messages to Telnyx and 

Telnyx responds back with 200 Keepalive SIP message, this was sufficient to keep the 

SIP trunk up in-service. 

2.3. Support 

For technical support on the Avaya products described in these Application Notes visit 

http://support.avaya.com. 

 

For support of Telnyx SIP Trunking Service visit the corporate Web page at: https://telnyx.com/ 

 

  

http://support.avaya.com/
https://telnyx.com/
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3. Reference Configuration 
Figure 1 illustrates the test configuration. The test configuration shows an enterprise site 

connected to the Telnyx SIP Trunk. Located at the enterprise site is an Avaya IP Office Server 

Edition and Avaya IP Office 500 V2 as an expansion. Endpoints include Avaya 1600 Series IP 

Telephones (with H.323 firmware), Avaya 9600 Series IP Telephones (with H.323 firmware), 

Avaya 1140e SIP Telephones, Avaya J189 Series SIP Phones, Avaya 1400 Series Digital 

Deskphones, Analog Telephone and a fax machine. The site also has a Windows 10 PC running 

Avaya IP Office Manager to configure the Avaya IP Office as well as Avaya Workplace Client 

for Windows for softphone testing. 

 

For security purposes, all Service Provider IP addresses or PSTN routable phone numbers used 

in the compliance test are not shown in these Application Notes. Instead, all IP addresses have 

been changed to a private format and all phone numbers have been obscured beyond the city 

code. 

 

 
Figure 1: Telnyx SIP Trunk to Avaya IP Office Topology 
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4. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

 

Equipment/Software  Release/Version 

Avaya 

Avaya IP Office Server Edition Version 11.1.1.1.0 build 18 

Avaya IP Office 500 V2 Version 11.1.1.1.0 build 18 

Avaya Voicemail Pro Client Version 11.1.1.1.0 

Avaya IP Office Manager Version 11.1.1.1.0 build 18 

Avaya 1608 Phone (H.323) 1.3.12 

Avaya 9611G Series Phone (H.323) 6.8.0 

Avaya J189 Series Phone (SIP) 4.0.10.0 

Avaya Workplace for Windows (SIP) 3.23.0.64 

Avaya 1140e (SIP) FW: 04.04.23.00.bin 

Avaya 1408 Digital Telephone R48 

Avaya Analogue Phone N/A 

Telnyx (Not Applicable) 

  

 

 

Note – Testing was performed with IP Office Server Edition with 500 V2 Expansion R11.1. 

Compliance Testing is applicable when the tested solution is deployed with a standalone IP 

Office 500 V2 and also when deployed with all configurations of IP Office Server Edition. Note: 

that IP Office Server Edition requires an Expansion IP Office 500 V2 to support analogue or 

digital endpoints or trunks, this includes T.38 fax.  

Telnyx prefers not to show their SIP trunk systems and software release. 
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5. Configure Avaya IP Office 
This section describes the Avaya IP Office configuration to support connectivity to the Telnyx 

SIP service. Avaya IP Office is configured through the Avaya IP Office Manager PC application. 

From a PC running the Avaya IP Office Manager application, select Start → Programs → IP 

Office → Manager to launch the application. Navigate to File → Open Configuration, select 

the proper Avaya IP Office system from the pop-up window, and log in with the appropriate 

credentials. 

 

 
 

A management window will appear similar to the one in the next section. All the Avaya IP 

Office configurable components are shown in the left pane known as the Navigation Pane. The 

pane on the right is the Details Pane. These panes will be referenced throughout the Avaya IP 

Office configuration. All licensing and feature configuration that is not directly related to the 

interface with the Service Provider (such as twinning) is assumed to already be in place. 
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5.1. Verify System Capacity 

Navigate to License → SIP Trunk Channels in the Navigation Pane. In the Details Pane, verify 

that the License Status is Valid and that the number of Instances is sufficient to support the 

number of SIP trunk channels provisioned by Telnyx. 
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5.2. LAN2 

In an Avaya IP Office, the LAN2 tab settings correspond to the Avaya IP Office WAN port 

(public network side) and the LAN1 tab settings correspond to the LAN port (private network 

side). For the compliance test, the LAN2 interface was used to the Avaya IP Office to the Telnyx 

SIP platform. 

 

To access the LAN2 settings, first navigate to System → IPOSE110 in the Navigation Pane 

where IPOSE110 is the name of the IP Office. Navigate to the LAN2 → LAN Settings tab in 

the Details Pane. The IP Address and IP Mask fields are the private interface of the IP Office. 

All other parameters should be set according to customer requirements. On completion, click the 

OK button (not shown). 

 

 
 

On the VoIP tab in the Details Pane, check the SIP Trunks Enable box to enable the 

configuration of SIP trunks. All other parameters shown are default values. 
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The RTP Port Number Range can be customized to a specific range of receive ports for the 

RTP media. Set Scope to RTP-RTCP and Initial keepalives to Enabled and Periodic timeout 

to 30. 

 

Avaya IP Office can also be configured to mark the Differentiated Services Code Point (DSCP) 

in the IP Header with specific values to support Quality of Services policies for both signalling 

and media. The DSCP field is the value used for media and the SIG DSCP is the value used for 

signalling. The specific values used for the compliance test are shown in the example below. All 

other parameters should be set according to customer requirements. On completion, click the OK 

button (not shown). 
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On the Network Topology tab, set the Firewall/NAT Type from the pull-down menu to Open 

Internet. With this configuration, the STUN Server IP Address and STUN Port are not used as 

NAT was not required for this configuration, therefore resulting in no requirement for a STUN 

server. The Use Network Topology Info in the SIP Line was set to None in Section 5.6.2. 

Default values were used for all other parameters. On completion, click the OK button (not 

shown). 
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5.3. IP Route 

In the reference configuration, the Primary server LAN1 port is physically connected to the local 

area network switch at the IP Office customer site. The IP Office LAN2 port is connected to the 

Telnyx network and has a default gateway of 50.xxx.xxx.1. 

 

To add an IP Route in the Primary server, do a right-click IP Route from the Navigation pane, 

and select New (not shown). To view or edit an existing route, select IP Route from the 

Navigation pane, and select the appropriate route from the Group pane. The following screen 

shows the Details pane with the relevant route using LAN2 as Destination. 
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5.4. System Telephony Settings 

Navigate to the Telephony → Telephony tab on the Details Pane. Choose the Companding 

Law typical for the enterprise location. For North America, ULAW is used. Uncheck the Inhibit 

Off-Switch Forward/Transfer box to allow call forwarding and call transfer to the PSTN via 

the Service Provider across the SIP trunk. On completion, click the OK button (not shown). 
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5.5.  VoIP Settings 

Navigate to the VoIP tab on the Details Pane. Check the available Codecs boxes as required. 

Note that G.711 ULAW 64K and G.711 ALAW 64K are greyed out and always available. Once 

available codecs are selected, they can be used or unused by using the horizontal arrows as 

required. Note that in test, G.711 ULAW 64K is set as the priority codec as G.711 ULAW 64K 

and G.729 are the codecs supported by Telnyx. 
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5.6. Administer SIP Line 

A SIP line is needed to establish the SIP connection between Avaya IP Office and TELNYX SIP 

platform. The recommended method for configuring a SIP Line is to use the template associated 

with these Application Notes. The template is an .xml file that can be used by IP Office Manager 

to create a SIP Line. Follow the steps in Section 5.6.1 to create the SIP Line from the template. 

 

Some items relevant to a specific customer environment are not included in the template or may 

need to be updated after the SIP Line is created. Examples include the following: 

• IP addresses 

• SIP Credentials (if applicable) 

• SIP URI entries 

• Setting of the Use Network Topology Info field on the Transport tab 

 

Therefore, it is important that the SIP Line configuration be reviewed and updated if necessary 

after the SIP Line is created via the template. The resulting SIP Line data can be verified against 

the manual configuration shown in Section 5.6.2. 

 

Also, the following SIP Line settings are not supported on Basic Edition: 

• SIP Line – Originator number for forwarded and twinning calls 

• Transport – Second Explicit DNS Server 

• SIP Credentials – Registration Required 

 

Alternatively, a SIP Line can be created manually. To do so, right-click Line in the Navigation 

Pane and select New → SIP Line. Then, follow the steps outlined in Section 5.6.2. 
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5.6.1. SIP Line From Template 

DevConnect generated SIP Line templates are always exported in an XML format. These XML 

templates do not include sensitive customer specific information and are therefore suitable for 

distribution. The XML format templates can be used to create SIP trunks on both IP Office 

Standard Edition (500 V2) and IP Office Server Edition systems. Alternatively, binary templates 

may be generated. However, binary templates include all the configuration parameters of the 

Trunk, including sensitive customer specific information. Therefore, binary templates should 

only be used for cloning trunks within a specific customer’s environment. 

 

Copy a previously created template file to a location (e.g., \temp) on the same computer where IP 

Office Manager is installed. To create the SIP Trunk from the template, right-click on Line in the 

Navigation Pane, then navigate to New → New from Template. 
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Navigate to the directory on the local machine where the template was copied and select the 

template as required. 

 

 
 

The SIP Line is automatically created and can be verified and edited as required using the 

configuration described in Section 5.6.2. 
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5.6.2. Manual SIP Line Configuration 

On the SIP Line tab in the Details Pane, configure the parameters below to connect to the SIP 

Trunking service. 

• Set ITSP Domain Name to a domain name provider by the Service Provider. 

sipdev.telnyx.com was used in this test configuration. 

• Set Local Domain Name to the LAN2 IP address of IP Office. 

• Set Check OOS to enable by checking on the checkbox. 

• Set National Prefix to 0 and International Prefix to 00 for number conversion as 

follows: outbound national and international called party numbers are converted to E.164 

format; inbound national and international calling party numbers are converted to 

diallable format. 

• Ensure the In Service box is checked. 

• Leave the Refresh Method at the default value of Auto which results in re-INVITE 

being used for Session Refresh. 

• Set Timer (seconds) to 300 seconds. This value allows the Session Refresh interval to be 

set by the network. 

• Set Incoming Supervised REFER and Outgoing Supervise REFER to Always. 

REFER is supported by Telnyx SIP platform. 

• Default values may be used for all other parameters. 

 

On completion, click the OK button (not shown). 
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Select the Transport tab and set the following: 

• Enter the proxy IP address of Telnyx SIP trunk in the ITSP Proxy Address field. 

• Set Use Network Topology Info to None as NAT is not used in this configuration and 

the Network Topology settings defined in Section 5.2 are not required. 

• Set Layer 4 Protocol to UDP. 

• Set Send Port and Listen Port to 5060. 

 

On completion, click the OK button (not shown). 

 

 
 

Select Call Details tab to define the SIP URIs that Avaya IP Office will accept on this line must 

be created. To create a SIP URI entry, select the Call Details tab and click on Add. 

 

 
 

A SIP URI is shown in this example that is used for calls to and from extensions that have a DDI 

number assigned to them. Additional SIP URI’s may be required for calls to services such as 

Voicemail Collect and the Mobile Twinning FNE, these would be for incoming calls only. 
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For the compliance test, SIP URI entries were created that matched any number assigned to an 

Avaya IP Office user. The entry was created with the parameters shown below. 

• Set Incoming Group. This is the value assigned for incoming calls that’s analysed in the 

Incoming Call Route settings described in Section 5.9. In the test environment a value of 

7 was used for the Telnyx. 

• Set Outgoing Group. This is the value assigned for outgoing calls that can be selected 

directly in the short code settings described in Section 5.7. In the test environment a 

value of 7 was used. 

• Set Max Sessions to the number of simultaneous SIP calls that are allowed using this SIP 

URI pattern. 

• Set Local URI, Contact and P Asserted ID to Auto for both the Display name and 

Content. On incoming calls, this will analyse the Request-Line sent by TELNYX and 

match to the SIP settings in the User profile as described in Section 5.8. On outgoing 

calls this will insert the SIP settings in the User profile into the relevant headers in the 

SIP messages. 

• Leave the Outgoing Calls, Forwarding/Twinning and Incoming Calls at their 

respective values of Caller, Caller and Called for the Local URI, Contact and P 

Asserted ID call details as shown in the screenshot below. 
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Select the VoIP tab to set the Voice over Internet Protocol parameters of the SIP line. Set the 

parameters as shown below: 

• Select System Default from the drop-down menu as system default codecs were already 

defined in Section 5.5. 

• Set the Fax Transport Support box to T.38 as this is the preferred method of fax 

transmission for Telnyx. 

• Set the DTMF Support field to RFC2833/RFC4733. This directs Avaya IP Office to 

send DTMF tones using RTP events messages as defined in RFC2833. 

• Check Media Security to Disabled. 

• Check the Re-invite Supported box to allow for codec re-negotiation in cases where the 

target of the incoming call or transfer does not support the codec originally negotiated. 

• Check the PRACK/100rel Supported box if early media is required. This was checked 

during compliance testing. 

• On completion, click the OK button (not shown). 

 

Default values may be used for all other parameters. 
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Select the SIP Advanced tab and set the following: 

• Check the Use + for International as E.164 numbering is used on the SIP Trunk. 

• Check Use PAI for Privacy. 

• Check Use Domain for PAI. 

• Default values may be used for all other parameters. 

 

 
 

Note: It is advisable at this stage to save the configuration as described in Section 5.11 to add 

the Line Group ID defined in Section 5.6.2 available. 
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5.7. Short Codes 

Define a short code to route outbound traffic to the SIP line and route incoming calls from 

mobility extensions to access Feature Name Extensions (FNE) hosted on IP Office. To create a 

short code, do a right-click Short Code in the Navigation Pane and select New. On the Short 

Code tab in the Details Pane, configure the parameters as shown below. 

• In the Code field, enter the dial string which will trigger this short code, followed by a 

semi-colon. The example shows 9N; which will be invoked when the user dials 9 

followed by the dialled number. 

• Set Feature to Dial. This is the action that the short code will perform. 

• Set Telephone Number to N. The Telephone Number field is used to construct the 

Request URI and To Header in the outgoing SIP INVITE message. 

• Set the Line Group Id to 7 for the outgoing line group number defined on the SIP URI 

tab on the SIP Line in Section 5.6.2. 

 

On completion, click the OK button (not shown). 
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5.8. User 

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP 

line defined in Section 5.6.2. To configure these settings, first navigate to User in the Navigation 

Pane. Select the User tab if any changes are required. 

 

The following example shows the configuration required for a SIP Endpoint.  

• Change the Name of the User if required. 

• Set the Password and Confirm Password. 

• Select the required profile from the Profile drop down menu. Basic User is commonly 

used; Power User can be selected for SIP softphone, WebRTC and Remote Worker 

endpoints. 
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Next select the SIP tab (not shown) in the Details Pane. To reach the SIP tab click the right 

arrow on the right hand side of the Details Pane until it becomes visible. The values entered for 

the SIP Name and Contact fields are used as the user part of the SIP URI in the From header 

for outgoing SIP trunk calls. As such, these fields should be set to User Name configured in the 

SIP Credentials tab in Section 5.6.2 assigned to the enterprise from Telnyx. 

 

 
 

The following screen shows the Mobility tab for user 4304. The Mobility Features and Mobile 

Twinning are checked. The Twinned Mobile Number field is configured with the number to 

dial to reach the twinned mobile telephone over the SIP Trunk. Other options can be set 

accordingly to customer requirements. 
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5.9. Incoming Call Routing 

An incoming call route maps an inbound DDI number on a specific line to an internal extension. 

To create an incoming call route, right-click Incoming Call Routes in the Navigation Pane and 

select New. On the Standard tab of the Details Pane, enter the parameters as shown below: 

• Set the Bearer Capability to Any Voice. 

• Set the Line Group Id to the incoming line group of the SIP line defined in Section 

5.6.2.  

• Set the Incoming Number to the incoming number that this route should match on. 

Matching is right to left. 

• Default values can be used for all other fields. 

 

 
 

On the Destinations tab, select the destination extension from the pull-down menu of the 

Destination field. On completion, click the OK button (not shown). In this example, incoming 

calls to the test DDI number +1201xxx0516 on line 7 are routed to extension 4304. 
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5.10. Fax 

At Release 11.1, both G.711 and T.38 Fax is supported on IP Office Server Edition when using 

an IP Office Expansion (500 V2). The Telnyx SIP Trunk testing was carried out using this 

configuration with only the analog extension for the fax machine on the Expansion. In this 

configuration, the T.38 fax settings are configured on the SIP line between the Expansion and the 

Server. 

 

The T.38 fax settings are defined on the SIP Line between the Expansion and the Server. Note 

that the VoIP settings for T.38 fax are required in three places in this configuration: 

• The SIP Line for the Telnyx SIP Trunk as described in Section 5.6.2. 

• The IP Office Line between the Server and the Expansion on the Expansion. 

• The IP Office Line between the Server and the Expansion on the Server. 

 

In all the above cases, the Fax Transport Support was set to T.38. The following screenshot 

shows the VoIP Settings for the IP Office Line between the Server and the Expansion on the 

Expansion: 
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The following screenshot shows the T38 Fax tab of the IP Office Line of the 500V2 expansion.  

 

 
 

The following shows the VoIP Settings tab in the IP Office Line for the Expansion in the Server 

configuration: 

 

 
 

Refer to Section 5.6.2 for the VoIP Settings on the SIP Line for the Telnyx SIP Trunk. 
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5.11. Save Configuration 

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the 

configuration performed in the preceding sections. A screen like the one shown below is 

displayed where the system configuration has been changed and needs to be saved on the system. 

Merge, Reboot, Timed or Reboot When Free can be selected from the Change Mode drop-

down menu based on the nature of the configuration changes made since the last save. Note that 

clicking OK may cause a service disruption. Click OK to save the configuration. 

 

 
 



 
KP; Reviewed: 

SPOC 11/3/2022 

Solution & Interoperability Test Lab Application Notes 

©2022 Avaya Inc. All Rights Reserved. 

30 of 36 

Telnyx_IPO11 

 

6. Configure the Telnyx SIP Trunking 
The configuration of the Telnyx SIP Trunk equipment used to support the SIP trunk is outside 

the scope of these Application Notes and will not be covered. To obtain further information on 

Telnyx SIP trunk and system configuration please contact an authorized Telnyx support. 

7. Verification Steps 
This section includes steps that can be used to verify that the configuration has been done 

correctly. 

7.1. SIP Trunk Status 

The status of the SIP trunk can be verified by opening the System Status application. This is 

found on the PC where IP Office Manager is installed in PC programs under Start →All 

Programs →IP Office →System Status (not shown). 

 

Log in to IP Office System Status at the prompt using the Control Unit IP Address for the IP 

Office. The User Name and Password are the same as those used for IP Office Manager. 
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From the left-hand menu expand Trunks and choose the SIP trunk (7 in this instance). The 

status window will show the status as being idle and time in state if the Trunk is operational. 
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7.2. Monitor 

The Monitor application can also be used to monitor and troubleshoot IP Office. Monitor can 

be accessed from Start → Programs → IP Office → Monitor. The application allows the 

monitored information to be customized. To customize, select the button that is third from the 

right in the screen below, or select Filters →Trace Options. The following screen shows the 

SIP tab, allowing configuration of SIP monitoring. In this example, the SIP Rx and SIP Tx 

boxes are checked. All SIP messages will appear in the trace with the color blue. To customize 

the color, right-click on SIP Rx or SIP Tx and select the desired color. 
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As an example, the following shows a portion of the monitoring window of an INVITE being 

sent between IP Office and the Service Provider. 
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8. Conclusion 
These Application Notes describe the procedures required to configure the connectivity between 

Avaya IP Office Server Edition R11.1 and Telnyx SIP Trunk service solution as shown in 

Figure 1. 

 

The reference configuration shown in these Application Notes is representative of a basic 

enterprise customer configuration and demonstrates Avaya IP Office Server Edition R11.1 can 

be configured to interoperate successfully with Telnyx’s SIP Trunk service. Telnyx’s SIP Trunk 

is a SIP-based Voice over IP solution providing businesses a flexible, cost-saving alternative to 

traditional hardwired telephony trunks. The service was successfully tested with a number of 

observations listed in Section 2.2. 
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9. Additional References  
Product documentation for Avaya products may be found at http://support.avaya.com.  

[1] Avaya IP Office™ Platform Start Here First, Release 11.1, Nov 2021. 

[2] Avaya IP Office™ Platform Server Edition Reference Configuration, Release 11.1, Jun 

2022. 

[3] Deploying IP Office™ Platform Server Edition Solution, Release 11.1, Nov 2021. 

[4] IP Office™ Platform 11.1, Deploying IP Office Essential Edition, Nov 2021. 

[5] IP Office™ Platform 11.1 Installing and Maintaining the Avaya IP Office™ Platform 

Application Server, Nov 2021. 

[6] Administering Avaya IP Office™ Platform with Web Manager, Release 11.1, Nov 2021. 

[7] Administering Avaya IP Office™ Platform with Manager, Release 11.1, Nov 2021. 

[8] IP Office™ Platform 11.1 Using Avaya IP Office™ Platform System Status, Apr 2022. 

[9] IP Office™ Platform 11.1 Using IP Office System Monitor, Apr 2022. 

[10] Using Avaya Workplace Client for Windows on IP Office, Nov 2021. 

[11] IP Office™ Platform 11.1 - Third-Party SIP Extension Installation Notes, Nov 2021. 

[12] Avaya IP Office Knowledgebase,  http://marketingtools.avaya.com/knowledgebase 
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