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 Avaya Solution & Interoperability Test Lab 
 

Application Notes for CSS Mindshare 100500 MaxPlus 

Dispatch Console integration with Avaya Aura® 

Communication Manager and Avaya Aura® Session 

Manager - Issue 1.0  
 

Abstract 
 

These Application Notes describe the configuration steps required to integrate CSS Mindshare 

100500 MaxPlus Dispatch Console 3.27.2 with Avaya Aura® Communication Manager 8.1 and 

Avaya Aura® Session Manager 8.1. CSS Mindshare 100500 MaxPlus Dispatch Console 

incorporates telephony to integrate both radio and telephone functions. This solution also 

includes Console Builder for creating a user console. 
 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as any observations noted in Section 2.2, to ensure that their own use 

cases are adequately covered by this scope and results. 
 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions. Testing was conducted via the DevConnect 

Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the configuration steps required to integrate CSS Mindshare 

100500 MaxPlus Dispatch Console with Avaya Aura® Communication Manager and Avaya 

Aura® Session Manager. CSS Mindshare 100500 MaxPlus Dispatch Console is purposely built 

for radio dispatch applications required for 24/7 operation. By integrating PC and audio 

processor components into a single device, CSS Mindshare 100500 Max Plus Dispatch Console 

provides a complete dispatch console workstation. 

2. General Test Approach and Test Results  
The interoperability testing scope is limited to MaxPlus Dispatch Console telephony integration 

with Session Manager and Communication Manager. The interoperability compliance test 

included feature and serviceability testing. The feature testing focused on establishing calls 

between MaxPlus Dispatch Console, Avaya SIP / H.323 desk phones, and the PSTN, and 

exercising basic telephony features, such as hold, mute, and transfer. Additional telephony 

features, such as call forward, call coverage, call park/unpark, and call pickup were also verified 

using Communication Manager Feature Access Codes (FACs).  

 

The serviceability testing focused on verifying that MaxPlus Dispatch Console comes back into 

service after IP network interruption. 

 

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members.  The 

jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent 

to the interoperability of the tested products and their functionalities.  DevConnect Compliance 

Testing is not intended to substitute full product performance or feature testing performed by 

DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or 

completeness of a DevConnect member’s solution. 

 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products.  The testing referenced in these DevConnect 

Application Notes included the enablement of supported encryption capabilities in the Avaya 

products.  Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

 

Support for these security and encryption capabilities in any non-Avaya solution component is 

the responsibility of each individual vendor.  Readers should consult the appropriate vendor-

supplied product documentation for more information regarding those products.  

 

For the testing associated with these Application Notes, the interface between Avaya systems 

and MaxPlus Dispatch Console did not include use of any specific encryption features as 

requested by CSS Mindshare. 
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2.1. Interoperability Compliance Testing 

Interoperability compliance testing covered the following features and functionality: 

 

▪ SIP user registration of MaxPlus Dispatch Console with Session Manager.  

▪ Calls between MaxPlus Dispatch Console and Avaya SIP / H.323 Deskphones with 

Direct IP Media (Shuffling) enabled and disabled.  

▪ Calls between MaxPlus Dispatch Console and the PSTN.  

▪ G.711MU and G.729 codec support.  

▪ Proper DTMF tone generation.  

▪ Basic telephony features including hold, mute, redial, multiple calls, and blind and 

attended call transfer.  

▪ Extended telephony features using Communication Manager FACs and for Call Forward, 

Call Park/Unpark, and Call Pickup.  

▪ Use of programmable buttons (Console Builder button controls) for speed dial on 

MaxPlus Dispatch Console.  

▪ Proper system recovery after a loss of IP connectivity. 

2.2. Test Results 

All test cases passed with the following observations: 

• Call Conferencing is not supported. 

• Voicemail MWI is currently not supported. 

• Long hold recall timer is not supported. 

• Audio tones for invalid numbers or outbound call restriction are not given but Console 

line indicator display notifications are made. 

• The Console line indicator display does not show called parties. The Console line 

Indicator displays the calling party only during ringing. Once that call is answered, the 

display clears. The display will continue to show the calling party if the call is not 

answered as per MaxPlus Dispatch Console design. If multiple consoles register to the 

same user, the display for the console(s) that did not answer the call will continue to 

show the calling party. 

• MDA (multi-device access) with non-TLS support will not alert DUT instances if an 

Avaya SIP phone is registered with the same user as the console. 

• There is no indication that MDA registration over the maximum allowed users is 

attempted. It is not allowed but the only indication is that the console buttons are inactive. 

Configuring the SIP user to not allow registration when the user limit is reached is 

recommended. 
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2.3. Support 

For technical support and information on MaxPlus Dispatch Console, contact CSS Mindshare 

Technical Support at: 

 

▪ Phone:  +1 402-261-8688 x2 

▪ Email:  techsupport@css-mindshare.com  

▪ Website: https://support.css-mindshare.com  

3. Reference Configuration 
Figure 1 illustrates a sample configuration with an Avaya SIP-based network: 

 

 
 

Figure 1: Avaya SIP Network with CSS Mindshare 100500 MaxPlus Dispatch Console 

 

  

https://support.css-mindshare.com/
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4. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

 

Equipment/Software Release/Version 

Avaya Aura® Communication Manager 

running on Virtual Machine 
01.0.890.0-27168 

Avaya Aura® Session Manager running on 

Virtual Machine 8.1.3.3_813310 

Avaya Aura® System Manager running on 

Virtual Machine 8.1.3.3.1013529 

Avaya Session Border Controller for 

Enterprise running on Virtual Machine 8.1.3.0-31-21052 

Avaya G450 Media Gateway 41.34.1 

Avaya Aura® Media Server 8.0.0.21 

Avaya 9641G IP Deskphone 6.8511 (H.323) 

Avaya J179 IP Phone 4.0.9.0.4 (SIP) 

CSS Mindshare 100500 MaxPlus Dispatch 

Console 

3.27.2 

Debian GNU/Linux 10 (buster) 

Gnome 3.30.2 

CSS Mindshare Console Builder 3.27.2 
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5. Configure Avaya Aura® Communication Manager 
This section provides the procedure for configuring Communication Manager. The procedure 

includes the following areas: 

 

▪ Verify Communication Manager license 

▪ Administer IP Network Region 

▪ Administer IP Codec Set 

 

Use the System Access Terminal (SAT) to configure Communication Manager and log in with 

appropriate credentials. 

 

Note: It is assumed that basic configuration of Communication Manager has already been 

completed, such as the SIP trunk to Session Manager. However, implementers should ensure 

sufficient Maximum Administered SIP Trunks licenses are available to accommodate the traffic 

between Communication Manager and Session Manager.  The SIP station configuration for  

MaxPlus Dispatch Console is configured through System Manager in Section 6.3. 

5.1. Verify Communication Manager license 

Using the SAT, verify that the number of OPS stations allowed in the system is sufficient for the 

number of SIP endpoints that will be deployed on the system-parameters customer-options 

form.  The license file installed on the system controls these options.  If a required feature is not 

enabled, contact an authorized Avaya sales representative. 

 

 
  

display system-parameters customer-options                      Page   1 of  12 

                                OPTIONAL FEATURES 

 

     G3 Version: V18                             Software Package: Enterprise 

       Location: 2                                System ID (SID): 1 

       Platform: 28                               Module ID (MID): 1 

 

                                                              USED 

                                Platform Maximum Ports: 48000    254 

                                      Maximum Stations:   150    119 

                              Maximum XMOBILE Stations: 36000      0 

                    Maximum Off-PBX Telephones - EC500:   150      0 

                    Maximum Off-PBX Telephones -   OPS:   150     63 

                    Maximum Off-PBX Telephones - PBFMC:   150      0 

                    Maximum Off-PBX Telephones - PVFMC:   150      0 

                    Maximum Off-PBX Telephones - SCCAN:     0      0 

                         Maximum Survivable Processors: 313        0 

 

        (NOTE: You must logoff & login to effect the permission changes.) 
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5.2. Administer IP Network Region 

In the ip-network-region form, the Authoritative Domain field is configured to match the 

domain name configured on Session Manager.  In this configuration, the domain name is 

avaya.com.  By default, IP-IP Direct Audio (shuffling) is enabled to allow audio traffic to be 

sent directly between IP endpoints without using media resources in the G450 Media Gateway or 

Media Server.  The ip-network-region form also specifies the Codec Set to be used for calls 

routed over the SIP trunk to Session Manager.   

 

 

5.3. Administer IP Codec Set 

In the ip-codec-set form, select the audio codec type supported for calls routed over the SIP 

trunk to MaxPlus Dispatch Console.  Note that IP codec set 1 was specified in IP Network 

Region 1 shown above.  The settings of the ip-codec-set form are shown below.  Ensure none is 

one of the Media Encryption options offered. MaxPlus Dispatch Console was tested using 

G.711MU and G.729 codecs. 

 

 

change ip-network-region 1                                      Page   1 of  20 

                               IP NETWORK REGION 

  Region: 1       NR Group: 1 

Location: 1       Authoritative Domain: avaya.com 

    Name: Main                  Stub Network Region: n 

MEDIA PARAMETERS                Intra-region IP-IP Direct Audio: yes 

      Codec Set: 1              Inter-region IP-IP Direct Audio: yes 

   UDP Port Min: 2048                      IP Audio Hairpinning? n 

   UDP Port Max: 3329 

DIFFSERV/TOS PARAMETERS 

 Call Control PHB Value: 46 

        Audio PHB Value: 46 

        Video PHB Value: 26 

802.1P/Q PARAMETERS 

 Call Control 802.1p Priority: 6 

        Audio 802.1p Priority: 6 

        Video 802.1p Priority: 5      AUDIO RESOURCE RESERVATION PARAMETERS 

H.323 IP ENDPOINTS                                       RSVP Enabled? n 

  H.323 Link Bounce Recovery? y 

 Idle Traffic Interval (sec): 20 

   Keep-Alive Interval (sec): 5 

            Keep-Alive Count: 5 

change ip-codec-set 1                                           Page   1 of   2 

 

                          IP MEDIA PARAMETERS 

    Codec Set: 1 

 

    Audio        Silence      Frames   Packet 

    Codec        Suppression  Per Pkt  Size(ms) 

 1: G.711MU           n         2        20 

 2: G.729             n         2        20 

 3: 

 4: 

 5: 

 6: 

 7: 

 

     Media Encryption                   Encrypted SRTCP: best-effort 

 1: 1-srtp-aescm128-hmac80 

 2: none 
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6. Configure Avaya Aura® Session Manager 
This section provides the procedure for configuring Session Manager. The procedures include 

the following areas: 

 

▪ Launch System Manager 

▪ Set Network Transport Protocol 

▪ Administer SIP User 

 

Note: It is assumed that Session Manager and Communication Manager SIP trunk connections 

are configured. This section will focus on the configuration of a SIP user for MaxPlus Dispatch 

Console. 

6.1. Launch System Manager 

Access System Manager web interface by entering http://<ip-address>/SMGR in a web 

browser, where <ip-address> is the IP address of System Manager. Log in with the appropriate 

credentials. 
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6.2. Set Network Transport Protocol 

From the System Manager Home screen, select Elements → Routing → SIP Entities and edit 

the SIP Entity for Session Manager shown below.  

 

 
 

Scroll down to the Listen Ports section and verify that the transport network protocol used by 

MaxPlus Dispatch Console is specified in the list below.  For the compliance test, MaxPlus 

Dispatch Console used TCP network transport. 
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6.3. Administer SIP Users 

A SIP user must be configured for MaxPlus Dispatch Console by the following steps. This 

configuration is automatically synchronized with Communication Manager. In Session Manager, 

select Users →User Management →Manage Users to display the User Management screen 

(not shown). Click + New to add a user. 

6.3.1. Identity 

Enter values for the following required attributes for a new SIP user in the User Profile screen:  

• Last Name:   Enter the last name of the user, e.g., Mindshare Console. 

• First Name:   Enter the first name of the user, e.g., Line 1. 

• Login Name:   Enter <extension>@<sip domain> of the 

user (e.g., 70111@avaya.com). 
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6.3.2. Communication Address 

Select the Communication Profile tab. Select Communication Address in the left list and click 

+ New (not shown). 

 

Enter the following attributes for the Communication Address:  

• Type:    Select Avaya SIP from the drop-down list. 

• Fully Qualified Address: Enter the extension number (e.g.,70111). 

• Domain:   Enter the domain (e.g., avaya.com). 
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6.3.3. Communication Profile Password 

Select Communication Profile Password on the left and in the Comm-Profile Password and 

Re-enter Comm-Profile Password fields, enter a password. This will be used to register the 

device. Click OK. 
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6.3.4. Session Manager Profile 

Click on the Session Manager Profile slide button. For Primary Session Manager, 

Origination Sequence, Termination Sequence, and Home Location (not shown), select the 

values corresponding to the applicable Session Manager and Communication Manager. Select 3 

for Max. Simultaneous Devices. Check Block New Registration When Maximum 

Registrations Active? to ensure any new console registration requests when the maximum 

concurrent registrations are being used will not drop a current registration to accept the new 

request. Retain the default values in the remaining fields. 

 

Note: The maximum supported number of simultaneous registrations with this user (MDA) is 

10. MaxPlus Dispatch Console interoperability testing used 3. 
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6.3.5. CM Endpoint Profile 

Click on the CM Endpoint Profile slide button. Fill in the following fields: 

• System:   Select the relevant Communication Manager SIP Entity 

(e.g., cm81). 

• Profile Type:   Select Endpoint. 

• Template:   Select J179_DEFAULT_CM_8_1. 

• Extension:   Enter the extension number (e.g., 70111). 

 

Click on Endpoint Editor in the Extension field to edit Communication Manager settings. Input 

the appropriate Coverage Path (not shown) configured to route unanswered calls to voicemail. 

Click Done to close the Endpoint Editor. Click Commit (not shown). 
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7. Configure CSS Mindshare 100500 MaxPlus Dispatch 
Console 

This section covers MaxPlus Dispatch Console configuration using Console Builder . The 

procedure covers the following areas: 

 

▪ Configure IP Address 

▪ Launch Console Builder 

▪ Configure Phone System Parameters 

▪ Administer IP Comms 

▪ Create Console Layout 

▪ Save Layout to Configuration File 

7.1. Configure IP Address 

MaxPlus Dispatch Console is configured for DHCP on power up. A static IP address can be 

assigned via the operating system desktop. Select the Settings button from the System Menu to 

open the Settings dialog. Click Network on the left side and click the settings icon under Wired. 
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Select the IPv4 tab. Assign an address by clicking Manual and input the appropriate network 

information. Interoperability testing used Automatic (DHCP). 
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7.2. Launch Console Builder 

The Console user interface is configured using Console Builder, an application resident on the 

MaxPlus Dispatch Console environment. Launch the application from the Administrator account 

on the system through the Applications→Mindshare→ConsoleBuilder selection. 
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7.3. Configure Phone System Parameters 

Select Setup → Setup Phone System from the menu. Input 20 hops for the Set SIP Packet 

Time to live entry. Select the TCP checkbox. The SIP Time Before Retry is set to 200 ms by 

default but can be adjusted to 2000 ms. Interoperability testing used 200 ms. The Digit Map can 

specify valid extensions in the system, e.g., 7xxxxx, if desired. Interoperability testing did not 

specify mapping. Retain the default values in the remaining fields. 
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7.4. Administer IP Comms 

Select Setup → Setup IP Comms from the menu to administer lines on the console. Select 

Phone in the Type column. Input 70111 in the Line Name column. Select uLaw or G.729 for 

the Codec column. 
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Click Setup SIP in the Channel Items column to open the Line SIP Setup dialog. Enter the 

following: 

• SIP Display Name:   Enter a name, e.g., Console1 line1. 

• SIP System User Name:  Enter the SIP username from Section 6.3.2 e.g., 

70111 

• SIP System Password:  Enter the password for the user from Section 6.3.3. 

• SIP Server Address:   Enter the Session Manager IP address e.g., 

10.64.110.212 

• SIP Server Port Number:  Enter 5060. 

• Backup SIP Server Port Number: Enter 5060. 

Retain the default values in the remaining fields. 
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7.5. Create Console Layout 

Insert and configure console elements used for the VoIP user. Elements include the Dial Keypad, 

Line Indicator, Phone Line, and Feature Buttons. Feature buttons employed for interoperability 

testing included Mute, Hold, Transfer, Blind Transfer, Call Pickup, Call Park, and Answer Back 

(Call Unpark) buttons. Console builder button controls provides a set of User Interface Functions 

that assign to buttons. These tools can be employed to provide additional functionality. A 

possible Call Park and Answer Back button configuration is shown below. For other button 

implementation configurations consult refer to [1] for details 

7.5.1. Dial Keypad 

Select Insert → Insert DTMF Keypad. Adjust the size and position of the keypad on the grid. 
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7.5.2. Line Indicator 

Select Insert → Insert Line Indicator. Adjust the size and position of the keypad on the grid. 

Mouse over the Line Indicator and right click on Properties. Select the Line defined in Section 

7.3 for Associated Line, e.g., 70111. 

 

 
 

  



 
Reviewed: RH 

SPOC 5/19/2022 

Solution & Interoperability Test Lab Application Notes 

©2022 Avaya Inc. All Rights Reserved. 

23 of 31 

100500MxPlsSM81 

 

7.5.3. Phone Line On/Offhook Button 

Select Insert → Insert Button Control. Adjust the size and position of the keypad on the grid. 

Mouse over the new button and right click on Properties. Select the Line defined in Section 7.3 

for Associated Line, e.g., 70111. Select Phone Line On/Offhook for User Interface Function. 

Input %VARLINENAME%[On|Off]Hook for Button Text to display the Line Name of the 

Associated Line selected above. 
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7.5.4. Call Park Button 

Note: In order for this particular button implementation to work, Communication Manager Class 

of Service Console Permissions should be set to ‘n’. Calls will park to the station’s extension by 

default. Refer to [1] for Console Permissions scope and details to determine applicability. 

Select Insert → Insert Button Control. Adjust the size and position of the button control on the 

grid. Mouse over the new button and right click on Properties. Select the Line defined in 

Section 7.3 for Associated Line, e.g., 70111. Select Phone Transfer-Line for User Interface 

Function. Input appropriate Button Text. 
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Select the Properties tab. Check Enable Autodial and Transfer Blind. Input the Feature 

Access Code assigned to Call Park on Communication Manager, e.g., *72. 
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7.5.5. Answer Back (Call Unpark) Button 

Select Insert → Insert Button Control. Adjust the size and position of the button control on the 

grid. Mouse over the new button and click properties. Select the Line defined in Section 7.3 for 

Associated Line, e.g., 70111. Select Phone AutoDial for User Interface Function. Input 

appropriate Button Text. 
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Select the Properties tab. Check Dial on Associated Line and Enable Autodial #2. Input the 

Feature Access Code assigned to Call Park on Communication Manager to Dial String when 

Clicked, e.g., *71. Input the line extension for Number 2, e.g., 70111. 
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7.6. Save Layout to Configuration File 

When the layout is complete, select File → Save As to save the layout configuration. The 

configuration file should be saved as /opt/mindshare/consolesuite/defConsole.cbd. The layout 

used for Interoperability tests included a second extension. 
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8. Verification Steps 
This section provides the tests that can be performed to verify proper configuration of MaxPlus 

Dispatch Console with Communication Manager and Session Manager. 

8.1. Launch Console 

Launch the application from the Administrator account on the system through the 

Applications→Mindshare→ConsoleBuilder menu selection. 

 

 
 

  



 
Reviewed: RH 

SPOC 5/19/2022 

Solution & Interoperability Test Lab Application Notes 

©2022 Avaya Inc. All Rights Reserved. 

30 of 31 

100500MxPlsSM81 

 

8.2. Registration to Session Manager 

Verify that MaxPlus Dispatch Console has successfully registered with Session Manager. In 

System Manager, navigate to Elements → Session Manager → System Status → User 

Registrations to check the registration status. Two lines for the console are registered as shown 

in the Prim column. The AST Device column is not checked. 

 

 
 

8.3. Basic Calls 

Verify basic telephony features by initiating and answering calls between MaxPlus Dispatch 

Console, Avaya H.323 phones, Avaya SIP phones, and other MaxPlus Dispatch Consoles. 

9. Conclusion 
These Application Notes have described the administration steps required to integrate MaxPlus 

100500 Dispatch Console 3.27.2 with Avaya Aura® Communication Manager 8.1 and Avaya 

Aura® Session Manager 8.1. CSS Mindshare 100500 MaxPlus Dispatch Console successfully 

registered with Session Manager as a SIP user and basic and supplementary telephony features 

were verified. All test cases passed with observations noted in Section Error! Reference source 

not found.. 

10. Additional References  
This section references product documentation relevant to these Application Notes. The 

following Avaya product documentation is available at support.avaya.com. 

 

[1] Administering Avaya Aura® Communication Manager, Issue 12, Release 8.1.x, July 2021 

[2] Administering Avaya Aura® Session Manager, Issue 10, Release 8.1.x, September 2021 

 

The following CSS Mindshare product documentation is accessible to registered users at 

customer.css-mindshare.com. 

 

[3] MS0101_UM_ConsoleApplicationManual 

http://support.avaya.com/
https://customer.css-mindshare.com/
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