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Abstract 
 

 

These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) trunking between BT SIP Trunk Service and Avaya IP Office R11.1. 

 

The BT SIP Trunking service referenced within these Application Notes is designed for business 

customers. Customers using this service can avail of Cloud Voice SIP Trunking and Hosted SIP 

Trunking services which are sold via BT Retail and Wholesale channels. The BT SIP Trunk 

Platform provides PSTN access via a SIP trunk connected to the BT Voice over Internet Protocol 

(VoIP) network as an alternative to legacy analogue or digital trunks. BT is a member of the 

Avaya DevConnect Service Provider program.  

 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as the observations noted in Section 2.2, to ensure that their own use cases 

are adequately covered by this scope and results. 
 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions. Testing was conducted via the DevConnect 

Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) trunking service between the BT network and an Avaya SIP-enabled enterprise solution. 

The Avaya solution consists of Avaya IP Office R11.1 and various Avaya endpoints, listed in 

Section 4. 

 

The BT SIP Trunking service referenced within these Application Notes is designed for business 

customers. Customers using this service can avail of Cloud Voice SIP Trunking and Hosted SIP 

Trunking services which are sold via BT Retail and Wholesale channels.  

 

Customers using this Avaya SIP-enabled enterprise solution with BT SIP Trunk can place and 

receive PSTN calls via a dedicated Internet connection and the SIP protocol. This converged 

network solution is an alternative to traditional PSTN trunks. This approach generally results in 

lower cost for the enterprise customer. 

 

2. General Test Approach and Test Results  
The general test approach was to configure a simulated enterprise site using Avaya IP Office 

R11.1 to connect to the BT SIP Platform. This configuration (shown in Figure 1) was used to 

exercise the features and functionality listed in Section 2.1. 

 

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The 

jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent 

to the interoperability of the tested products and their functionalities. DevConnect Compliance 

Testing is not intended to substitute full product performance or feature testing performed by 

DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or 

completeness of a DevConnect member’s solution. 

 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products. The testing referenced in these DevConnect 

Application Notes included the enablement of supported encryption capabilities in the Avaya 

products. Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

 

Support for these security and encryption capabilities in any non-Avaya solution component is 

the responsibility of each individual vendor. Readers should consult the appropriate vendor-

supplied product documentation for more information regarding those products. 

 

For the testing associated with this Application Note, the interface between Avaya systems and 

the BT SIP platform do not include use of any specific encryption features. 
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2.1. Interoperability Compliance Testing 

Avaya IP Office was connected to the BT SIP Trunk via a direct connection over the internet. 

To verify SIP trunking interoperability the following features and functionality were exercised 

during the interoperability compliance test: 

• Incoming PSTN calls to various phone types including H.323, SIP and analogue 

telephones at the enterprise. Calls were routed to the enterprise across the SIP trunk from 

BT. 

• Outgoing PSTN calls from various phone types including H.323, SIP and analogue 

telephones at the enterprise. Calls were routed from the enterprise across the SIP trunk to 

BT. 

• Calls using the G.722, G.711A, G.711MU and G.729 codecs. 

• DTMF transmission using RFC 2833 with successful Voice Mail for inbound and 

outbound calls. 

• Inbound and outbound PSTN calls to/from Avaya IX Workplace™ for Windows 

softphone client. 

• Various call types including local, long distance, international, toll free (outbound) and 

directory assistance. 

• Caller ID presentation and Caller ID restriction. 

• User features such as hold and resume, transfer, and conference. 

• Call transfer to PSTN. 

• Off-net call forwarding and mobile twinning. 

• Outbound calls to the BT SIP platform using Class 5 CLIP. 
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2.2. Test Results 

Interoperability testing of the sample configuration was completed with successful results for the 

BT SIP Trunk with the following observations: 

• T.38 or G711 fax transmission were not tested as fax was not offered during the 

compliance testing as part of the BT SIP Trunk solution. 

• Ensure the “Check OOS” box is unchecked on the SIP Line configuration as per Section 

5.5.2. BT didn’t respond to OPTIONs requests sent by Avaya IP Office. If the “Check 

OOS” box is enabled and no reply to an OPTIONs message is received, the trunk is taken 

out of service. 

• No inbound toll-free numbers were tested, however routing of inbound DDI numbers and 

the relevant number translation was successfully tested. 

• Access to Emergency Services was not tested as no test call had been booked by the 

Service Provider with the Emergency Services Operator. 

 

2.3. Support 

For technical support on the Avaya products described in these Application Notes visit 

http://support.avaya.com. 

 

For technical support on BT products please use the following web link. 

http://btbusiness.custhelp.com/app/contact 

http://support.avaya.com/
http://btbusiness.custhelp.com/app/contact
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3. Reference Configuration 
Figure 1 illustrates the test configuration. The test configuration shows an enterprise site 

connected to the BT SIP Trunking Service. Located at the enterprise site is an Avaya IP Office 

Server Edition and Avaya IP Office 500 V2 as an Expansion. Endpoints include Avaya 1600 

Series IP Telephones (with H.323 firmware), Avaya 9600 Series IP Telephones (with H.323 

firmware), Avaya J179 SIP Telephones, Avaya 1140e SIP Telephones, Avaya 1400 Series 

Digital Deskphones, Analog Telephone and a fax machine. The site also has a Windows 7 PC 

running Avaya IP Office Manager to configure the Avaya IP Office as well as Avaya Workplace 

Client for Windows (SIP) softphone client. 

 

For security purposes, all Service Provider IP addresses or PSTN routable phone numbers used 

in the compliance test are not shown in these Application Notes. Instead, all IP addresses have 

been changed to a private format and all phone numbers have been obscured beyond the city 

code. 

 

 
 

Figure 1: BT SIP Trunk to Avaya IP Office Topology 
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4. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

 

Equipment/Software Release/Version 

Avaya 

Avaya IP Office Server Edition (Primary Server) 

• Avaya IP Office Voicemail Pro 

Version 11.1.0.1.0 build 95 

Version 11.1.0.1 Build 10 

Avaya IP Office IP500 V2 (Expansion System) Version 11.1.0.1.0 build 95 

Avaya IP Office Manager Version 11.1.0.1.0 build 95 

Avaya 1608 Phone (H.323) 1.3.12 

Avaya 9611G Series Phone (H.323) 6.8.0 

Avaya J179 Series Phone (SIP) 4.0.4.0.10 

Avaya 1140e (SIP) FW: 04.04.23.00.bin 

Avaya Workplace Client for Windows (SIP)  3.11.0.44.25 

Avaya 1408 Digital Telephone R48 

Avaya Analogue Phone N/A 

BT 

Ribbon Q21 SBC v9.3.26.1. 

Broadworks IP Comms Release 22 

 

Note – Testing was performed with IP Office Server Edition with 500 V2 Expansion R11.1. 

Compliance Testing is applicable when the tested solution is deployed with a standalone IP 

Office 500 V2 and when deployed with all configurations of IP Office Server Edition. Note: that 

IP Office Server Edition requires an Expansion IP Office 500 V2 to support analogue or digital 

endpoints or trunks, this includes T.38 fax. 
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5. Configure Avaya IP Office 
This section describes the Avaya IP Office configuration to support connectivity to the BT SIP 

platform. Avaya IP Office is configured through the Avaya IP Office Manager PC application. 

From a PC running the Avaya IP Office Manager application, select Start → Programs → IP 

Office → Manager to launch the application. Navigate to File → Open Configuration, select 

the appropriate Avaya IP Office system from the pop-up window and log in with the appropriate 

credentials. 

 

 
 

A management window will appear similar to the one in the next section. All the Avaya IP 

Office configurable components are shown in the left pane known as the Navigation Pane. The 

pane on the right is the Details Pane. These panes will be referenced throughout the Avaya IP 

Office configuration. All licensing and feature configuration that is not directly related to the 

interface with the Service Provider is assumed to already be in place. 

 

 



CMN; Reviewed: 

SPOC 1/10/2021 

Solution & Interoperability Test Lab Application Notes 

©2021 Avaya Inc. All Rights Reserved. 

8 of 34 

BT_IPO11 

 

5.1. Verify System Capacity 

Navigate to License in the Navigation Pane. In the Details Pane verify that the License Status 

for SIP Trunk Channels is Valid and that the number of Instances is sufficient to support the 

number of SIP trunk channels provisioned by BT. 
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5.2. LAN2 Settings 

In an Avaya IP Office, the LAN2 tab settings correspond to the Avaya IP Office WAN port 

(public network side) and the LAN1 tab settings correspond to the LAN port (private network 

side). 

 

In the test configuration, the LAN2 port was used to connect the Avaya IP Office to the external 

internet. To access the LAN2 settings, first navigate to System → GSSCP_IPO_SE in the 

Navigation Pane where GSSCP_IPO_SE is the name of the IP Office. Navigate to the LAN2 → 

LAN Settings tab in the Details Pane. The IP Address and IP Mask fields are the public 

interface of the IP Office. All other parameters should be set according to customer 

requirements. On completion, click the OK button (not shown). 

 

 

 

On the VoIP tab in the Details Pane, the H323 Gatekeeper Enable box is checked to allow the 

use of Avaya IP Telephones using the H.323 protocol. Set H.323 Signalling over TLS to 

Preferred to allow IP Office H323 endpoints to use TLS for signalling. Check the SIP Trunks 

Enable box to enable the configuration of SIP trunks. If SIP Endpoints are to be used such as the 

Avaya IX Workplace for Windows and the Avaya 1140e, the SIP Registrar Enable box must 

also be checked. The Domain Name has been set to the customer premises equipment domain 

“avaya.com”. If the Domain Name is left at the default blank setting, SIP registrations may use 

the IP Office LAN1 IP Address. All other parameters shown are default values. 

 

The RTP Port Number Range can be customized to a specific range of receive ports for the 

RTP media. Set Scope to RTP-RTCP and Initial keepalives to Enabled and Periodic timeout 

to 30. This will cause the IP Office to send RTP and RTCP keepalive packets at the beginning of 

the calls and every 30 seconds thereafter if no other RTP/RTCP traffic is present. 
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Avaya IP Office can also be configured to mark the Differentiated Services Code Point (DSCP) 

in the IP Header with specific values to support Quality of Services policies for both signalling 

and media. The DSCP field is the value used for media and the SIG DSCP is the value used for 

signalling. The specific values used for the compliance test are shown in the example below. All 

other parameters should be set according to customer requirements. On completion, click the OK 

button (not shown). 
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On the Network Topology tab, set the Firewall/NAT Type from the pulldown menu to Open 

Internet. With this configuration, the STUN Server IP Address and STUN Port are not used as 

NAT was not required for this configuration, therefore resulting in no requirement for a STUN 

server. The Use Network Topology Info in the SIP Line was set to None in Section 5.5.2. Set 

Binding Refresh Time (seconds) to 300. This value is used to determine the frequency at which 

Avaya IP Office will send SIP OPTIONS messages to the service provider. Default values were 

used for all other parameters. On completion, click the OK button (not shown). 
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5.3. System Telephony Settings 

Navigate to the Telephony → Telephony tab on the Details Pane. Choose the Companding 

Law typical for the enterprise location. For Europe, ALAW is used. Uncheck the Inhibit Off-

Switch Forward/Transfer box to allow call forwarding and call transfer to the PSTN via the 

Service Provider across the SIP trunk. On completion, click the OK button (not shown). 

 

 
 



CMN; Reviewed: 

SPOC 1/10/2021 

Solution & Interoperability Test Lab Application Notes 

©2021 Avaya Inc. All Rights Reserved. 

13 of 34 

BT_IPO11 

 

5.4. VoIP Settings 

Navigate to the VoIP tab on the Details Pane. Check the available Codecs boxes as required. 

Note that G.711 ULAW 64K and G.711 ALAW 64K are greyed out and always available. Once 

available codecs are selected, they can be used or unused by using the horizontal arrows as 

required. Note that in test, G.722 64K, G.711 ALAW 64K, G.711 ULAW 64K and G729(a)8K 

CS-ACELP are the codecs’s supported on the BT SIP Trunk. The order of priority can be 

changed using the vertical arrows. On completion, click the OK button (not shown). 
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5.5. SIP Line 

A SIP line is needed to establish the SIP connection between Avaya IP Office and the BT SIP 

platform. The recommended method for configuring a SIP Line is to use the template associated 

with these Application Notes. The template is an .xml file that can be used by IP Office Manager 

to create a SIP Line. Follow the steps in Section 5.5.1 to create the SIP Line from the template. 

 

Some items relevant to a specific customer environment are not included in the template or may 

need to be updated after the SIP Line is created. Examples include the following: 

• IP addresses 

• SIP Credentials (if applicable) 

• SIP URI entries 

• Setting of the Use Network Topology Info field on the Transport tab 

 

Therefore, it is important that the SIP Line configuration be reviewed and updated if necessary, 

after the SIP Line is created via the template. The resulting SIP Line data can be verified against 

the manual configuration shown in Section 5.5.2. 

 

Also, the following SIP Line settings are not supported on Basic Edition: 

• SIP Line – Originator number for forwarded and twinning calls 

• Transport – Second Explicit DNS Server 

• SIP Credentials – Registration Required 

 

Alternatively, a SIP Line can be created manually. To do so, right-click Line in the Navigation 

Pane and select New → SIP Line. Then, follow the steps outlined in Section 5.5.2. 
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5.5.1. SIP Line From Template 

DevConnect generated SIP Line templates are always exported in an XML format. These XML 

templates do not include sensitive customer specific information and are therefore suitable for 

distribution. The XML format templates can be used to create SIP trunks on both IP Office 

Standard Edition (500 V2) and IP Office Server Edition systems. Alternatively, binary templates 

may be generated. However, binary templates include all the configuration parameters of the 

Trunk, including sensitive customer specific information. Therefore, binary templates should 

only be used for cloning trunks within a specific customer’s environment. 

 

Copy a previously created template file to a location (e.g., \temp) on the same computer where IP 

Office Manager is installed. To create the SIP Trunk from the template, right-click on Line in the 

Navigation Pane, then navigate to New → New from Template. 
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Navigate to the directory on the local machine where the template was copied and select the 

template as required. 

 

 
 

The SIP Line is automatically created and can be verified and edited as required using the 

configuration described in Section 5.5.2. 
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5.5.2. Manual SIP Line Configuration 

On the SIP Line tab in the Details Pane, configure the parameters below to connect to the BT 

SIP Trunking service. 

• Set ITSP Domain Name to a domain name provider by the Service Provider if required, 

interopc1.domain was used in this configuration. 

• Set National Prefix to 0 and International Prefix to 00 so that national and international 

numbers can be correctly identified. 

• Ensure the In Service box is checked. 

• Ensure the Check OOS box is unchecked as BT didn’t respond to OPTIONs requests 

sent by Avaya as per Section 2.2. 

• Leave the Refresh Method at the default value of Auto. 

• Leave Timer (seconds) at the default value of On Demand. This value allows the 

Session Refresh interval to be set by the network. 

• Set Incoming Supervised REFER and Outgoing Supervise REFER to Auto. 

• Default values may be used for all other parameters. 

 

On completion, click the OK button (not shown). 
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Select the Transport tab and set the following: 

• Set ITSP Proxy Address to the IP addresses of the BT SIP proxy. 

• Set Use Network Topology Info to None as NAT is not used in this configuration and 

the Network Topology settings defined in Section 5.2 are not required. 

• Set Layer 4 Protocol to UDP. 

• Set Send Port and Listen Port to 5060. 

 

On completion, click the OK button (not shown). 

 

 

 

After the SIP line parameters are defined, the SIP credentials used for registration and 

authorisation on this line must be created. To define SIP credentials, first select the SIP 

Credentials tab. Click the Add button and the New SIP Credentials area will appear at the 

bottom of the pane. 
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Enter the registration credentials provided by BT as shown below. Click the OK button. 

 

 
 

After the SIP line parameters are defined, the SIP URIs that Avaya IP Office will accept on this 

line must be created. To create a SIP URI entry, select the Call Details tab and click on Add. 
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For the compliance test, SIP URI entries were created that matched any number assigned to an 

Avaya IP Office user. The entry was created with the parameters shown below. 

• Set Incoming Group. This is the value assigned for incoming calls that’s analysed in the 

Incoming Call Route settings described in Section 5.8. In the test environment a value of 

17 was used for the BT SIP platform. 

• Set Outgoing Group. This is the value assigned for outgoing calls that can be selected 

directly in the short code settings described in Section 5.6. In the test environment a 

value of 17 was used.  

• Select the SIP Credentials defined previously in the Credentials drop down menu. 

• Set Max Sessions to the number of simultaneous SIP calls that are allowed using this SIP 

URI pattern. 

• Set Local URI, Contact and P Asserted ID to Use Internal Data for both the Display 

name and Content. On incoming calls, this will analyse the Request-Line sent by BT and 

match to the SIP settings in the User profile as described in Section 5.7. On outgoing 

calls this will insert the SIP settings in the User profile into the relevant headers in the 

SIP messages. 

• Leave the Outgoing Calls, Forwarding/Twinning and Incoming Calls at their 

respective default values of Caller, Original Caller and Called for the Local URI, 

Contact and P Asserted ID call details. 

 

 
 

The following screenshot shows the completed configuration: 

 

 
 



CMN; Reviewed: 

SPOC 1/10/2021 

Solution & Interoperability Test Lab Application Notes 

©2021 Avaya Inc. All Rights Reserved. 

21 of 34 

BT_IPO11 

 

Select the VoIP tab to set the Voice over Internet Protocol parameters of the SIP line. Set the 

parameters as shown below: 

• Select System Default from the drop-down menu as system default codecs were already 

defined in Section 5.4. 

• Set the Fax Transport Support box to None as fax was not tested as part of the BT SIP 

solution. 

• Set the DTMF Support field to RFC2833/RFC4733. This directs Avaya IP Office to 

send DTMF tones using RTP events messages as defined in RFC2833. 

• Set Media Security field to Same as System (Disabled). 

• Check the Local Hold Music box. 

• Check the Re-invite Supported box to allow for codec re-negotiation in cases where the 

target of the incoming call or transfer does not support the codec originally negotiated. 

• Check the PRACK/100rel Supported box if early media is required. This was checked 

during compliance testing. 

• On completion, click the OK button (not shown). 

 

Default values may be used for all other parameters. 
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Select the SIP Advanced tab and set the following: 

• Check the Add user=phone box to send SIP parameter user with the value phone to the 

From and To Headers in outgoing calls. 

• Default values may be used for all other parameters. 

 

 
 

Note: It is advisable at this stage to save the configuration as described in Section 5.9 to make 

the Line Group ID defined in Section 5.5.2 available. 
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5.6. Short Codes 

Define a short code to route outbound traffic to the SIP line. To create a short code, right-click 

Short Code in the Navigation Pane and select New. On the Short Code tab in the Details Pane, 

configure the parameters as required. The example below shows the configuration used during 

testing for national numbers. 

• In the Code field, enter the dial string which will trigger this short code, followed by a 

semi-colon. The example shows 9N; which will be invoked when the user dials 9 

followed by the dialled number. 

• Set Feature to Dial. This is the action that the short code will perform. 

• Set Telephone Number to N. The Telephone Number field is used to construct the 

Request URI and To Header in the outgoing SIP INVITE message. 

• Set the Line Group Id to the outgoing line group number defined on the SIP URI tab on 

the SIP Line in Section 5.5.2. 

 

On completion, click the OK button (not shown). 
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5.7. User 

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP 

line defined in Section 5.5.2. To configure these settings, first navigate to User in the Navigation 

Pane. Select the User tab if any changes are required. 

 

The following example shows the configuration required for a SIP Endpoint.  

• Change the Name of the User if required. 

• Set the Password and Confirm Password. 

• Select the required profile from the Profile drop down menu. Basic User is commonly 

used; Power User can be selected for SIP softphone, WebRTC and Remote Worker 

endpoints. 

 

 
 

SIP endpoints require setting of the SIP Registrar Enable as described in Section 5.2. 
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Next, select the SIP tab in the Details Pane. To reach the SIP tab click the right arrow on the 

right-hand side of the Details Pane until it becomes visible. The values entered for the SIP 

Name and Contact fields are used as the user part of the SIP URI in the From header for 

outgoing SIP trunk calls. These allow matching of the SIP URI for incoming calls without 

having to enter this number as an explicit SIP URI for the SIP line (Section 5.5.2). As such, 

these fields should be set to one of the DDI numbers assigned to the enterprise from BT. 

 

 
 

Note: The Anonymous box can be used to restrict Calling Line Identity (CLIR). 

 

The following screen shows the Mobility tab for user 89110. The Mobility Features and Mobile 

Twinning are checked. The Twinned Mobile Number field is configured with the number to 

dial to reach the twinned mobile telephone over the SIP Trunk. Other options can be set 

accordingly to customer requirements. 
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5.8. Incoming Call Routing 

An incoming call route maps an inbound DDI number on a specific line to an internal extension. 

To create an incoming call route, right-click Incoming Call Routes in the Navigation Pane and 

select New. On the Standard tab of the Details Pane, enter the parameters as shown below: 

• Set the Bearer Capability to Any Voice. 

• Set the Line Group Id to the incoming line group of the SIP line defined in Section 

5.5.2. 

• Set the Incoming Number to the incoming number that this route should match on. 

Matching is right to left. 

• Default values can be used for all other fields. 

 

 
 

On the Destinations tab, select the destination extension from the pull-down menu of the 

Destination field. On completion, click the OK button (not shown). In this example, incoming 

calls to the test DDI number 441xxxxxx202 on line 17 are routed to extension 89110. 

 

 
 



CMN; Reviewed: 

SPOC 1/10/2021 

Solution & Interoperability Test Lab Application Notes 

©2021 Avaya Inc. All Rights Reserved. 

27 of 34 

BT_IPO11 

 

5.9. Save Configuration 

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the 

configuration performed in the preceding sections. A screen like the one shown below is 

displayed where the system configuration has been changed and needs to be saved on the system. 

Merge, Reboot, Timed or RebootWhen Free can be selected from the Change Mode drop-

down menu based on the nature of the configuration changes made since the last save. Note that 

clicking OK may cause a service disruption. Click OK to save the configuration. 
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6. BT SIP Trunk Configuration 
The configuration of the BT equipment used to support BT’s SIP platform is outside of the scope 

of these Application Notes and will not be covered. To obtain further information on BT 

equipment and system configuration please contact an authorized BT representative as listed in 

Section 2.3. 

7. Verification Steps 
This section includes steps that can be used to verify that the configuration has been done 

correctly. 

7.1. SIP Trunk status 

The status of the SIP trunk can be verified by opening the System Status application. This is 

found on the PC where IP Office Manager is installed in PC programs under Start →All 

Programs →IP Office →System Status (not shown). 

 

Log in to IP Office System Status at the prompt using the Control Unit IP Address for the IP 

Office. The User Name and Password are the same as those used for IP Office Manager. 
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From the left-hand menu expand Trunks and choose the SIP trunk (17 in this instance). The 

status window will show the status as being idle and time in state if the Trunk is operational. 

 

 
 

7.2. Monitor 

The Monitor application can also be used to monitor and troubleshoot IP Office. Monitor can 

be accessed from Start → Programs → IP Office → Monitor. The application allows the 

monitored information to be customized. To customize, select the button that is third from the 

right in the screen below, or select Filters →Trace Options. The following screen shows the 

SIP tab, allowing configuration of SIP monitoring. In this example, the SIP Rx and SIP Tx 

boxes are checked. All SIP messages will appear in the trace with the colour blue. To 

customize the colour, right-click on SIP Rx or SIP Tx and select the desired colour. 
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As an example, the following shows a portion of the monitoring window of an OPTIONS 

message being sent between IP Office and the Service Provider. 
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8. Conclusion 
These Application Notes describe the procedures required to configure the connectivity between 

Avaya IP Office R11.1 and BT SIP Trunk Service shown in Figure 1. 

 

The reference configuration shown in these Application Notes is representative of a basic 

enterprise customer configuration and demonstrates Avaya IP Office can be configured to 

interoperate successfully with BT SIP Trunk. BT SIP Trunk is a SIP-based Voice over IP 

solution providing businesses a flexible, cost-saving alternative to traditional hardwired 

telephony trunks. The service was successfully tested with a number of observations listed in 

Section 2.2. 
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[9] IP Office™ Platform 11.1 Using IP Office System Monitor, Apr 2020. 
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10. Appendix A: Class 5 CLIP 
During the compliance testing, BT requested to test Class 5 CLIP PBX passthrough testing. This 

scenario is to verify if the PBX supports Class-5 CLIP. The PBX should be able to send a Class-

5 CLIP on outbound calls but accept incoming calls on BT DDIs configured in IP Office as per 

Section 5.8. The following configuration and screenshots explain the required set-up on IP 

Office to successfully test Class 5 CLIP PBX passthrough testing. 

 

For this particular test scenario, a SIP URI entry was created to send a Class-5 CLIP for 

outbound calls but accept incoming calls on BT DDIs configured in IP Office. The entry was 

created with the parameters shown below. 

• Set Incoming Group. In the test environment a value of 17 was used for the BT SIP 

platform. 

• Set Outgoing Group. This is the value assigned for outgoing calls that can be selected 

directly in the short code settings. For this particular test scenario, a value of 16 was used.  

• Select the SIP Credentials defined previously in the Credentials drop down menu as 

described in Section 5.5.2. 

• Set Max Sessions to the number of simultaneous SIP calls that are allowed using this SIP 

URI pattern. 

• Set Local URI and Contact to the Class 5 CLIP as specified by BT. 0800800800 was 

configured for both the Display and Content parameters. 

• Set P Asserted ID to a recognized DDI associated with the BT SIP platform so outbound 

calls will be completed successfully.  

• Leave the Outgoing Calls, Forwarding/Twinning and Incoming Calls at their 

respective default values of Caller, Original Caller and Called for the Local URI, 

Contact and P Asserted ID call details. 
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Define a short code to route outbound traffic to use Class 5 CLIP for outbound calls. To create a 

short code as described in Section 5.6, right-click Short Code in the Navigation Pane and select 

New. On the Short Code tab in the Details Pane, configure the parameters as required. 

• In the Code field, enter the dial string which will trigger this short code, followed by a 

semi-colon. The example shows 7N; which will be invoked when the user dials 7 

followed by the dialled number. 

• Set Feature to Dial. This is the action that the short code will perform. 

• Set Telephone Number to N. The Telephone Number field is used to construct the 

Request URI and To Header in the outgoing SIP INVITE message. 

• Set the Line Group Id to the outgoing line group number 16 as defined for the SIP URI 

on the above page. This will ensure that the Class 5 CLIP will be sent on outbound calls. 

 

On completion, click the OK button (not shown). 

 

 

 

The following screenshot shows the completed configuration for both the SIP URI created in 

Section 5.5.2 and the SIP URI created for the Class 5 CLIP test scenario. 
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