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 Avaya Solution & Interoperability Test Lab 
 

Application Notes for CSS Mindshare 100500 MaxPlus 

Dispatch Console integration with Avaya IP Office 11.1 - 

Issue 1.0  
 

Abstract 
 

These Application Notes describe the configuration steps required to integrate CSS Mindshare 

100500 MaxPlus Dispatch Console 3.27.2 with Avaya IP Office Server Edition 11.1 and Avaya 

IP Office 500 V2 Expansion System 11.1. CSS Mindshare 100500 MaxPlus Dispatch Console 

incorporates telephony to integrate both radio and telephone functions. This solution also 

includes Console Builder for creating a user console. 
 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as any observations noted in Section 2.2, to ensure that their own use 

cases are adequately covered by this scope and results. 
 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions. Testing was conducted via the DevConnect 

Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the configuration steps required to integrate CSS Mindshare 

100500 MaxPlus Dispatch Console 3.27.2 with Avaya IP Office Server Edition 11.1 and Avaya IP 

Office 500 V2 Expansion System 11.1. CSS Mindshare 100500 MaxPlus Dispatch Console is 

purposely built for radio dispatch applications required for 24/7 operation. By integrating PC and 

audio processor components into a single device, CSS Mindshare 100500 Max Plus Dispatch 

Console provides a complete dispatch console workstation. 

2. General Test Approach and Test Results  
The interoperability testing scope is limited to MaxPlus Dispatch Console telephony integration 

with IP Office. The interoperability compliance test included feature and serviceability testing. 

The feature testing focused on establishing calls between MaxPlus Dispatch Console, Avaya SIP 

/ H.323 desk phones, and the PSTN, and exercising basic telephony features, such as 

hold/resume, mute, and transfer. MaxPlus Dispatch does not support conferencing. Additional 

telephony features, such as call forward, call coverage, call park/unpark, and call pickup were 

also verified using IP Office Short Codes. The serviceability testing focused on verifying that 

MaxPlus Dispatch Console comes back into service after IP network interruption. 

 

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members.  The 

jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent 

to the interoperability of the tested products and their functionalities.  DevConnect Compliance 

Testing is not intended to substitute full product performance or feature testing performed by 

DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or 

completeness of a DevConnect member’s solution. 

 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products.  The testing referenced in these DevConnect 

Application Notes included the enablement of supported encryption capabilities in the Avaya 

products.  Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

 

Support for these security and encryption capabilities in any non-Avaya solution component is 

the responsibility of each individual vendor.  Readers should consult the appropriate vendor-

supplied product documentation for more information regarding those products.  

 

For the testing associated with these Application Notes, the interface between Avaya systems 

and MaxPlus Dispatch Console did not include use of any specific encryption features as 

requested by CSS Mindshare. 
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2.1. Interoperability Compliance Testing 

Interoperability compliance testing covered the following features and functionality: 

 

▪ SIP user registration of MaxPlus Dispatch Console with IP Office. 

▪ Calls between MaxPlus Dispatch Console and Avaya SIP / H.323 Deskphones with 

Direct IP Media (Shuffling) enabled and disabled. 

▪ Calls between MaxPlus Dispatch Console and the PSTN.  

▪ G.711MU and G.729 codec support.  

▪ Proper DTMF tone generation.  

▪ Basic telephony features including hold/resume, mute, redial, and blind and attended call 

transfer. 

▪ Extended telephony features using IP Office short codes for Call Forwarding, Call 

Park/Unpark, and Call Pickup All.  

▪ Use of programmable buttons (Console Builder button controls) for Call Pickup All on 

MaxPlus Dispatch Console.  

▪ Proper system recovery after a loss of IP connectivity. 

2.2. Test Results 

All test cases passed with the following observations: 

• Call Conferencing is not supported. 

• Voicemail MWI is not supported. 

• Call on Hold Reminder is not supported. 

• Audio tones for invalid numbers or outbound call screening are not given but MaxPlus 

Dispatch Console line indicator display notifications are made. 

• MaxPlus Dispatch Console line indicator display does not show called parties. In most 

cases, MaxPlus Dispatch Console line indicator displays the calling party only during 

ringing. Once that call is answered, the display clears. The display will continue to show 

the calling party if the call is not answered as per MaxPlus Dispatch Console design. 

• If a call is answered, MaxPlus Dispatch Console line indicator display may show the 

calling party. Variations occur among the type of endpoints calling and whether they are 

registered to IP Office Server Edition or IP Office 500 V2 Expansion System. 

• Calling the IP Office voicemail system via IP Office default short code *17 is not 

reliable. This is addressed in future MaxPlus Dispatch Console release 3.28.3. 

• Calls cannot be forwarded on busy/ring no answer/forward unconditional to MaxPlus 

Dispatch Console. This is addressed in future MaxPlus Dispatch Console release 3.28.4. 
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2.3. Support 

For technical support and information on MaxPlus Dispatch Console, contact CSS Mindshare 

Technical Support at: 

 

▪ Phone:  +1 402-261-8688 x2 

▪ Email:  techsupport@css-mindshare.com  

▪ Website: https://support.css-mindshare.com  

3. Reference Configuration 
Figure 1 illustrates a sample configuration with an Avaya SIP-based network: 

 

 
 

Figure 1: Avaya SIP Network with CSS Mindshare 100500 MaxPlus Dispatch Console 

 

  

https://support.css-mindshare.com/
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4. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

 

Equipment/Software Release/Version 

Avaya IP Office 500 V2 Expansion 11.1.2.2.0 

Avaya IP Office Server Edition 11.1.2.2.0 

Avaya 9641G IP Deskphone 6.8.3.0.4 (H.323) 

Avaya J179 IP Phone 4.0.7.0.7 (SIP) 

CSS Mindshare 100500 MaxPlus Dispatch 

Console 

3.27.2 

Debian GNU/Linux 10 (buster) 

Gnome 3.30.2 

CSS Mindshare Console Builder 3.27.2 

 

Note: Compliance Testing is applicable when the tested solution is deployed with a standalone 

IP Office 500 V2 and also when deployed with IP Office Server Edition in all configurations. 
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5. Configure Avaya IP Office Server Edition 
This section provides the procedures for configuring Avaya IP Office Server Edition. The 

procedures include the following areas: 

 

• Verify License 

• Obtain LAN IP Address 

• Administer SIP Registrar 

• Administer IP Codecs 

• Administer SIP Extension for MaxPlus Dispatch Console 

• Administer SIP User for MaxPlus Dispatch Console 

 

Note: This section covers the configuration of Avaya IP Office Server Edition, but the 

configuration is the same for Avaya IP Office 500 V2 Expansion System. 
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5.1. Verify License 

From a PC with IP Office Admin Suite installed, invoke IP Office Manager. Select the proper 

primary IP Office system (not shown), and log in using the appropriate credentials. Avaya IP 

Office Manager for Server Edition screen is displayed. From the configuration tree in the left 

pane, select License under the IP Office system that will be used to display a list of licenses in 

the right pane. Verify that there are sufficient licenses for 3rd Party IP Endpoints. 
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5.2. Obtain LAN IP Address 

From the configuration tree in the left pane, select System to display the System screen for the IP 

Office Server Edition in the right pane. Select the LAN1 tab, followed by the LAN Settings sub-

tab in the right pane. Make a note of the IP Address (e.g., 10.64.110.65), which will be used in 

Section 6.4 to configure MaxPlus Dispatch Console. 
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5.3. Administer SIP Registrar 

Select the VoIP sub-tab in the LAN1 tab. Ensure that SIP Registrar Enable is checked and 

enter a valid Domain Name. In the compliance testing, the SIP Domain Name field was set to 

avaya.com. TCP transport protocol was enabled for the Layer 4 Protocol, which was also used 

by MaxPlus Dispatch Console. 
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5.4. Administer IP Codecs 

Select the VoIP tab in System. The VoIP sub-tab displays Selected codecs at the system level. 

G.711 ULAW and G.711 ALAW are selected. G.729 can also be configured at the system level. 
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5.5. Administer SIP Extension for MaxPlus Dispatch Console 

From the configuration tree in the left pane, right-click on Extension and select New → SIP 

from the pop-up list (not shown) to add a new SIP extension. Enter the desired extension for the 

Base Extension field as shown below. In this example, MaxPlus Dispatch Console was assigned 

extension 70010. This is the extension that MaxPlus Dispatch Console will use to register with 

IP Office Server Edition. Enter an appropriate Phone Password. This will be used by MaxPlus 

Dispatch Console to register to IP Office Server. 
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Select the VoIP tab. The Codec Selection is configured using the system level defaults from 

Section 5.4 of G.711 ULAW and G.711 ALAW. Enable Allow Direct Media Path so that 

audio/RTP may flow directly between two SIP endpoints without using media resources in 

Avaya IP Office Server Edition. Select disabled for Media Security. 
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5.6. Administer SIP User for MaxPlus Dispatch Console 

From the configuration tree in the left pane, right-click on User and select New from the pop-up 

list (not shown). Enter a value for the Name field (e.g., Mindshare Cons2). For the Extension 

field, enter the SIP extension administered in Section 5.5 (e.g., 70010). 
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Select the Voicemail tab and select Voicemail On to enable voicemail for MaxPlus Dispatch 

Console. Specify a Voicemail Code to be used when logging into voicemail. 
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Select the Telephony tab followed by the Call Settings sub-tab. Note the settings for the user. 
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6. Configure CSS Mindshare 100500 MaxPlus Dispatch 
Console 

This section covers MaxPlus Dispatch Console configuration using Console Builder . The 

procedure covers the following areas: 

 

▪ Configure IP Address 

▪ Launch Console Builder 

▪ Configure Phone System Parameters 

▪ Administer IP Comms 

▪ Create Console Layout 

▪ Save Layout to Configuration File 

6.1. Configure IP Address 

Note: MaxPlus Dispatch Console requires two IP addresses. The second IP address is internally 

assigned as the next numerical assignment, e.g., if a static address of 10.64.10.51 is assigned to 

the console, 10.64.10.52 is internally assigned. Static IP addresses can avoid address conflicts. 

MaxPlus Dispatch Console is configured for DHCP on power up. A static IP address can be 

assigned via the operating system desktop. Select the Settings button from the System Menu to 

open the Settings dialog. Click Network on the left side to access the Wired properties. 
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Click the Wired Settings button to the right of the Connected slider. After the Wired settings 

appear, click on IPv4. Assign an address by clicking the Manual radio button and input the 

appropriate network information. In this case, an internal IP address of 10.64.10.51 is assigned 

(and implicitly 10.64.10.52). 
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6.2. Launch Console Builder 

The Console user interface is configured using Console Builder, an application resident on the 

MaxPlus Dispatch Console environment. Launch the application from the Administrator account 

on the system through the Applications → Mindshare → ConsoleBuilder selection. 

 

 
 

  



 
RH; Reviewed: 

SPOC 10/6/2022 

Solution & Interoperability Test Lab Application Notes 

©2022 Avaya Inc. All Rights Reserved. 

19 of 34 

100500MxPlsIPO 

 

6.3. Configure Phone System Parameters 

Select Setup → Setup Phone System from the menu. Input 20 hops for Set SIP Packet Time to 

live. Select the TCP checkbox. Set SIP Time Before Retry to 2000 ms. Clear any default digit 

mappings. Retain the default values in the remaining fields. 
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6.4. Administer IP Comms 

Select Setup → Setup IP Comms from the menu to administer lines on the console. Select 

Phone in the Type column. Input 70010 in the Line Name column. Select uLaw or G.729 for the 

Codec column. 
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Click Setup SIP in the Channel Items column to open the Line SIP Setup dialog. Enter the 

following: 

• SIP Display Name:   Enter a name, e.g., Console2. 

• SIP System User Name:  Enter the extension from Section 5.5 e.g., 

70010. 

• SIP System Password:  Enter the password for the extension administered 

in Section 5.5. 

• SIP Server Address:   Enter IP Office Server Edition IP address from 

Section 5.2, e.g., 10.64.110.65. 

• SIP Server Port Number:  Enter 5060. 

• Backup SIP Server Port Number: Enter 5060. 

 

Retain the default values in the remaining fields. 
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6.5. Create Console Layout 

Insert and configure console elements used for the VoIP user. Elements include the Dial Keypad, 

Line Indicator, Phone Line, Close Console, and Feature buttons. Feature buttons employed for 

interoperability testing included Mute, Hold, Transfer, Redial, Call Pickup Any, Call Park, and 

Call Unpark buttons. Console builder button controls provide a set of User Interface Functions 

that are assigned to buttons. These tools can be employed to provide additional functionality. 

Basic controls and a possible Call Park and Call Pickup button configuration are illustrated. For 

other button implementation configurations consult refer to [2]. 

6.5.1. Dial Keypad 

Select Insert → Insert DTMF Keypad. Adjust the size and position of the keypad on the grid. 
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6.5.2. Line Indicator 

Select Insert → Insert Line Indicator. Adjust the size and position of the Line Indicator on the 

grid. Mouse over the Line Indicator and right click on Properties. Select the Line defined in 

Section 6.4 for Associated Line, e.g., 70010. 
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6.5.3. Phone Line On/Offhook Button 

Select Insert → Insert Button Control. Adjust the size and position of the On/Offhook button 

on the grid. Mouse over the new button and right click on Properties. Select the Line defined in 

Section 6.4 for Associated Line, e.g., 70010. Select Phone Line On/Offhook for User Interface 

Function. Input %VARLINENAME%[On|Off]Hook for Button Text to display the line name of 

the Associated Line selected. 
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6.5.4. Call Park Button 

Select Insert → Insert Button Control. Adjust the size and position of the Call Park button on 

the grid. Mouse over the new button and right click on Properties. Select the Line defined in 

Section 6.4 for Associated Line, e.g., 70010. Select Phone Transfer-Line for User Interface 

Function. Input appropriate Button Text. 
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Select the Properties tab. Check Enable Autodial. Input the Short Code assigned to Call Park 

on IP Office, e.g., *37*123456#. In this case, the park slot number used is 123456. 
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6.5.5. Call Unpark Button 

Select Insert → Insert Button Control. Adjust the size and position of the Call Unpark button 

on the grid. Mouse over the new button and click properties. Select the Line defined in Section 

6.4 for Associated Line, e.g., 70010. Select Phone AutoDial for User Interface Function. Input 

appropriate Button Text. 
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Select the Properties tab. Check Dial on Associated Line. Input the short Code to unpark the 

call on IP Office for Dial String when Clicked, e.g., *38*123456# that uses the analogous park 

slot number 123456 used in Section 6.5.4. 
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6.6. Save Layout to Configuration File 

When the layout is complete, select File → Save As to save the layout configuration. The 

configuration file should be saved as /opt/mindshare/consolesuite/defConsole.cbd. 
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7. Verification Steps 
This section provides the tests that can be performed to verify proper configuration of MaxPlus 

Dispatch Console with IP Office. 

7.1. Launch Console 

Launch the application from the Administrator account on the system through the Applications 

→ Mindshare → ConsoleBuilder menu selection. 
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7.2. Registration Status 

Verify that MaxPlus Dispatch Console has successfully registered with IP Office. From a PC 

with IP Office Admin Suite installed, invoke IP Office System Status, navigate to the MaxPlus 

Dispatch Console SIP extension and verify Media Stream is set to RTP, Layer 4 Protocol is set 

to TCP, and Current State is shown as Idle.  
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7.3. Basic Calls 

Establish a call between MaxPlus Dispatch Console and a local Avaya SIP desk phone. In IP 

Office System Status, navigate to the MaxPlus Dispatch Console SIP extension and verify that 

the Current State is Connected as shown. Verify two-way audio. 
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8. Conclusion 
These Application Notes have described the administration steps required to integrate CSS 

Mindshare MaxPlus 100500 Dispatch Console 3.27.2 with Avaya IP Office Server Edition 11.1 

and Avaya IP Office 500 V2 Expansion System 11.1. CSS Mindshare 100500 MaxPlus Dispatch 

Console successfully registered with IP Office as a SIP user, and basic and supplementary 

telephony features were verified. All test cases passed with observations noted in Section 2.2. 

9. Additional References  
This section references product documentation relevant to these Application Notes. The 

following Avaya product documentation is available online at support.avaya.com. 

 

[1] Administering Avaya IP Office Platform™ with Manager 

 

The following CSS Mindshare product documentation is accessible to registered users at 

customer.css-mindshare.com. 

 

[2] MS0101_UM_ConsoleApplicationManual, Revision 1.15, June 23, 2022 
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